Last modified: 2012-09-07 12:34:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 33612 - IndexPager::reallyDoQuery (BlockListPager) when searching for blocked IP
IndexPager::reallyDoQuery (BlockListPager) when searching for blocked IP
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.18.x
All All
: Normal normal (vote)
: ---
Assigned To: Karun
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2012-01-09 19:28 UTC by MTecknology
Modified: 2012-09-07 12:34 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MTecknology 2012-01-09 19:28:38 UTC
When searching for a blocked IP I see this Database error page.

A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

    (SQL query hidden)

from within function "IndexPager::reallyDoQuery (BlockListPager)". Database returned error "1: ERROR: operator does not exist: text <= integer LINE 1: ...(ipb_range_start LIKE '%' ) AND (ipb_range_start <= 0) AND ... ^ HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.".
Comment 1 MTecknology 2012-01-09 19:32:13 UTC
This happens when I search for an IP from the form on the Special:BlockList page.
Comment 2 Mark A. Hershberger 2012-01-11 17:27:11 UTC
What do you see after adding the following to your LocalSettings?

$wgShowSQLErrors = true;
$wgDebugDumpSql  = true;
Comment 3 Marcin Cieślak 2012-03-14 22:26:05 UTC
I can't reproduce this using trunk. 

Which version exactly are you using? There were some changes in 1.18.1 - can you check?

I would be grateful for output of

http://yourwiki/w/index.php?title=Special:Version

as well as output with

$wgShowSQLErrors = true;
$wgDebugDumpSql  = true;
$wgShowDBErrorBacktrace = true;
$wgShowExceptionDetails = true;
$wgDebugLogFile = "somefilewebservercanwriteto.log";

You can send the log privately to me if it contains some private information
Comment 4 Karun 2012-09-07 12:34:46 UTC
Hello,
As far as I can see it works for me. Unless you provide further information as requested we cant fix any problem if there is any.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links