Last modified: 2012-04-16 09:16:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32442 - Special:GlobalUsers redirects your search for no reason to Special:ListUsers
Special:GlobalUsers redirects your search for no reason to Special:ListUsers
Status: RESOLVED DUPLICATE of bug 31638
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
https://meta.wikimedia.org/wiki/Speci...
: code-update-regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 16:27 UTC by MA
Modified: 2012-04-16 09:16 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MA 2011-11-16 16:27:08 UTC
Try making a search at [[m:Special:GlobalUsers]] (just enter a name) and hit the search button. Your search is redirected for no reason to [[Special:ListUsers]] showing you local results, when global results where wanted.

I've just detected this, which didn't happened before, but after the most recent MediaWiki update.

Best regards.
Comment 1 Platonides 2011-11-16 16:28:51 UTC
The hidden input title contains Special:ListUsers. Fixing that will make it work.
Comment 2 MA 2011-11-16 16:29:23 UTC
(In reply to comment #0)
> Try making a search at [[m:Special:GlobalUsers]] (just enter a name) and hit
> the search button. Your search is redirected for no reason to
> [[Special:ListUsers]] showing you local results, when global results where
> wanted.
> 
> I've just detected this, which didn't happened before, but after the most
> recent MediaWiki update.
> 
> Best regards.

Fix: [[Special:ListUsers]] should be [[m:Special:ListUsers]] above.
Comment 3 Platonides 2011-11-16 17:02:57 UTC
Seems to work in trunk.
Comment 4 Platonides 2011-11-16 17:12:49 UTC
Was fixed in r100516. Marked for deployment.
Comment 5 Platonides 2011-11-16 17:13:20 UTC

*** This bug has been marked as a duplicate of bug 31638 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links