Last modified: 2013-02-01 15:48:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31638 - Special:GlobalUsers pagination broken (incorrectly links to Special:ListUsers)
Special:GlobalUsers pagination broken (incorrectly links to Special:ListUsers)
Status: VERIFIED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CentralAuth (Other open bugs)
unspecified
All All
: Normal normal (vote)
: MW 1.19 version
Assigned To: Nobody - You can work on this!
: need-integration-test, platformeng
: 31224 32278 32442 33597 34533 (view as bug list)
Depends on:
Blocks: 29876 30185 31217
  Show dependency treegraph
 
Reported: 2011-10-12 02:56 UTC by Jesse (Pathoschild)
Modified: 2013-02-01 15:48 UTC (History)
14 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jesse (Pathoschild) 2011-10-12 02:56:56 UTC
The pagination links on [[Special:GlobalUsers]] incorrectly link to [[Special:ListUsers]]. Try clicking "next" or one of the pagination limit links on <http://meta.wikimedia.org/wiki/Special:GlobalUsers/Global_bot>.
Comment 1 Mark A. Hershberger 2011-10-15 22:03:24 UTC
tagging bugs for Marcus to look at
Comment 2 Derk-Jan Hartman 2011-10-22 20:55:41 UTC
Fixed in r100516
Comment 3 Derk-Jan Hartman 2011-10-22 21:02:05 UTC
Was this a 1.18 bug ?  1.18 was branched three months ago, and this change that I think caused it was from late september...
Comment 4 Mark A. Hershberger 2011-10-23 20:37:40 UTC
Since Jesse pointed to a page on Meta shortly after the deployment of 1.18, I assumed that it was included in 1.18.  Maybe something else was going on?
Comment 5 Platonides 2011-11-16 17:13:20 UTC
*** Bug 32442 has been marked as a duplicate of this bug. ***
Comment 6 MA 2011-11-17 20:15:28 UTC
*** Bug 32278 has been marked as a duplicate of this bug. ***
Comment 7 Jens 2011-11-17 20:43:57 UTC
I'm sorry, but I can't see that the bug is fixed.

When I'm loading Special:GlobalUsers/Global_bot, I see the first 50 entries only. When I'm clicking "next 50", I'm directed to: http://meta.wikimedia.org/w/index.php?title=Special:ListUsers&offset=MenoBot&group=Global_bot
but I should be directed to: http://meta.wikimedia.org/w/index.php?title=Special:GlobalUsers&offset=MenoBot&group=Global_bot to see the next 50 entries.
Comment 8 Mark A. Hershberger 2011-11-21 00:19:47 UTC
We close bugs when the code has been fixed, not when it is put into production.  You should see this change live in a few days.

Feel free to ask me what is up if this hasn't been fixed by next week.
Comment 9 John Du Hart 2012-01-08 02:44:39 UTC
*** Bug 31224 has been marked as a duplicate of this bug. ***
Comment 10 Mark A. Hershberger 2012-01-09 01:20:52 UTC
Reopening after I verified (when Jens pointed it out to me in email today) that this is *not* fixed.
Comment 11 Techman224 2012-01-09 04:51:51 UTC
*** Bug 33597 has been marked as a duplicate of this bug. ***
Comment 12 Antoine "hashar" Musso (WMF) 2012-01-12 21:21:25 UTC
The fix r100516 was deployed by Reedy January 4th with r108070

Can you please retest?
Comment 13 Mark A. Hershberger 2012-01-25 15:36:47 UTC
Looks to be fixed on beta.wmflabs.org, but not the link in Comment #0
Comment 14 Nemo 2012-01-29 13:50:29 UTC
There's also bug 34016.
Comment 15 Nemo 2012-07-31 08:38:48 UTC
*** Bug 34533 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links