Last modified: 2012-08-04 20:49:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31929 - phpunt test failure BlockTest::testInitializerFunctionsReturnCorrectBlock
phpunt test failure BlockTest::testInitializerFunctionsReturnCorrectBlock
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Unit tests (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2011-10-24 19:49 UTC by OverlordQ
Modified: 2012-08-04 20:49 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description OverlordQ 2011-10-24 19:49:10 UTC
1) BlockTest::testInitializerFunctionsReturnCorrectBlock
Argument 1 passed to Block::equals() must be an instance of Block, null given, called in /var/www/thedarkcitadel.com/w/tests/phpunit/includes/BlockTest.php on line 70 and defined

/var/www/thedarkcitadel.com/w/includes/Block.php:136
/var/www/thedarkcitadel.com/w/tests/phpunit/includes/BlockTest.php:70
/var/www/thedarkcitadel.com/w/tests/phpunit/MediaWikiTestCase.php:61
/var/www/thedarkcitadel.com/w/tests/phpunit/MediaWikiPHPUnitCommand.php:31
/var/www/thedarkcitadel.com/w/tests/phpunit/phpunit.php:60
Comment 1 Chad H. 2011-10-24 19:51:06 UTC
This happens from time to time in Sqlite too, never managed to track down a cause.
Comment 2 Antoine "hashar" Musso (WMF) 2011-10-27 12:54:17 UTC
taking it since it is related to PHPUnit.

Is there any way to reproduce it reliably? Did you run the full test suite or used filters?
Comment 3 Max Semenik 2011-10-31 16:56:51 UTC
Fixed in r101365.
Comment 4 OverlordQ 2011-10-31 17:10:25 UTC
Error still appearing in r101366
Comment 5 Max Semenik 2011-10-31 17:11:09 UTC
My bad:P
Comment 6 Rob Lanphier 2012-01-10 19:23:09 UTC
Antoine tells me he can't reproduce this one

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links