Last modified: 2013-09-04 11:47:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31006 - warnings thrown during search using Postgresql
warnings thrown during search using Postgresql
Status: RESOLVED DUPLICATE of bug 35043
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
1.17.x
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2011-09-19 19:16 UTC by John Andrea
Modified: 2013-09-04 11:47 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description John Andrea 2011-09-19 19:16:26 UTC
With Postgresql 8.4.8 as the backend, a search throws up this warning at the top of the results page

"Warning: pg_fetch_result(): supplied argument is not a valid PostgreSQL result resource in /data/services/wiki/mediawiki-1.17.0/includes/search/SearchPostgres.php on line 156"

The page does continue what what seems to be valid results.


Section of code:

function searchQuery( $term,
...
$searchstring = $this->parseQuery( $term );
$SQL = "SELECT to_tsquery($prefix $searchstring)";
$res = $this->db->query($SQL);
$top = pg_fetch_result($res,0,0);
Comment 1 Brion Vibber 2011-09-19 19:49:59 UTC
This code has been changed in 1.18 and later. Can you test with a SVN checkout from REL1_18 branch?

http://www.mediawiki.org/wiki/Download_from_SVN#Download
Comment 2 John Andrea 2011-09-19 19:57:29 UTC
I may have some time to try 1.18 soon.
Comment 3 Marcin Cieślak 2012-03-08 21:53:53 UTC

*** This bug has been marked as a duplicate of bug 35043 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links