Last modified: 2013-02-10 08:05:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30804 - RTL display is broken with ?debug=true
RTL display is broken with ?debug=true
Status: RESOLVED DUPLICATE of bug 27025
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2011-09-07 17:57 UTC by Amir E. Aharoni
Modified: 2013-02-10 08:05 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2011-09-07 17:57:37 UTC
Right-to-left style is only partially applied in debug mode.

From IRC:

aharoni	if i try to use ?debug=true, right-to-left style is only partially applied to the page.
RoanKattouw	Yes
RoanKattouw	That's because Krinkle and TrevorParscal broke debug mode for RTL
RoanKattouw	I tried to convince Krinkle to undo that but he disagreed
aharoni	Oh, nice.
RoanKattouw	This was broken in Berlin and discovered in Haifa
aharoni	RoanKattouw, is this debug mode for RTL bug documented?
RoanKattouw	aharoni: I don't think so, no
SPQRobin	aharoni: I mentioned it on [[mw:Directionality support]]
RoanKattouw	File a bug
Comment 1 Brion Vibber 2011-09-07 20:35:29 UTC
See also bug 27025 -- assuming that bug hasn't actually been implemented without getting resolved as fixed, CSS is still being loaded via ResourceLoader in debug mode, and RTL transforms should work fine in theory.

Lack of RTL transforms when loading files directly was one of the reasons given for bug 27025 being a tricky thing to fix.
Comment 2 Krinkle 2011-09-07 20:37:21 UTC

*** This bug has been marked as a duplicate of bug 27025 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links