Last modified: 2013-04-08 11:02:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29277 - [Regression] MediaWiki:Filepage.css not loaded on repo itself
[Regression] MediaWiki:Filepage.css not loaded on repo itself
Status: VERIFIED FIXED
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.17.x
All All
: High critical (vote)
: 1.19.0 release
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 29068
  Show dependency treegraph
 
Reported: 2011-06-05 13:52 UTC by Krinkle
Modified: 2013-04-08 11:02 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2011-06-05 13:52:32 UTC
Wikimedia Commons has created [[commons:MediaWiki:Filepage.css]] and it's being loaded on all wmf-wikis[1], however it's not loaded on Commons itself at all!

I'm assuming this is a bug otherwise convert to enhancement request.


--
Krinkle


[1] Due to bug 28083 it was also loaded before this page was created, but that aside..
Comment 1 p858snake 2011-06-05 23:02:48 UTC
(In reply to comment #0)
> ....and it's being
> loaded on all wmf-wikis[1], ...
um... what?!
Comment 2 Derk-Jan Hartman 2011-06-06 09:44:19 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > ....and it's being
> > loaded on all wmf-wikis[1], ...
> um... what?!

New feature. Idea is that files on the shared repo have description pages from the shared repo, but so far it was impossible to use anything but inline css on those pages. That was becoming a bit problematic, so Filepage.css was created with the idea that imagepages for images on the shared repo, also include a CSS page from the shared repo.

Now the issue is that this page is not automatically included on the shared repo itself.
Comment 3 p858snake 2011-06-06 09:56:02 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > (In reply to comment #0)
> > > ....and it's being
> > > loaded on all wmf-wikis[1], ...
> > um... what?!
> 
> New feature. Idea is that files on the shared repo have description pages from
> the shared repo, but so far it was impossible to use anything but inline css on
> those pages. That was becoming a bit problematic, so Filepage.css was created
> with the idea that imagepages for images on the shared repo, also include a CSS
> page from the shared repo.
> 
> Now the issue is that this page is not automatically included on the shared
> repo itself.

Where was this discussed? vague memories from the last time I saw this discussed is that we didn't want remote wikis touching locals ones (in any form).
Comment 5 Chad H. 2011-06-29 00:08:38 UTC
Fixed in r91031.
Comment 6 Krinkle 2012-01-25 23:58:22 UTC
Don't know what or where, but it's still not loaded. Maybe it got lost in merges ?
Comment 8 Krinkle 2012-03-02 21:19:43 UTC
Moving to 1.19.0 as 1.18 is released.
Comment 9 Rob Lanphier 2012-03-14 16:56:53 UTC
There appears to be a workaround, and this doesn't seem like something that will affect a lot of small wikis, so I'm removing this as a 1.19 tarball release blocker.
Comment 10 Alexandre Emsenhuber [IAlex] 2012-03-18 22:34:13 UTC
Working correctly on MediaWiki 1.19; marking as FIXED.
Comment 11 Krinkle 2012-03-18 23:48:10 UTC
Nice!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links