Last modified: 2012-05-24 15:01:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29205 - Fix "drag and drop" functionality in LiquidThreads (it does not work in all cases of possible moves)
Fix "drag and drop" functionality in LiquidThreads (it does not work in all c...
Status: RESOLVED DUPLICATE of bug 28407
Product: MediaWiki extensions
Classification: Unclassified
LiquidThreads (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 21:11 UTC by T. Gries
Modified: 2012-05-24 15:01 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description T. Gries 2011-05-29 21:11:22 UTC
Hello,

I found a bug in Lqt which broke the "Drag to new location" function.

http://www.mediawiki.org/wiki/Special:Code/MediaWiki/89121

The patch has been already applied in http://www.translatewiki.net so
that you can check and confirm that the functionality - which was broken for
a while - is indeed restored.

Tom

The patch is so simple

Index: trunk/extensions/LiquidThreads/LiquidThreads.php
===================================================================
--- trunk/extensions/LiquidThreads/LiquidThreads.php	(revision 89120)
+++ trunk/extensions/LiquidThreads/LiquidThreads.php	(revision 89121)
@@ -71,7 +71,7 @@
 $wgResourceModules['ext.liquidThreads'] = $lqtResourceTemplate + array(
 	'styles' => array( 'lqt.css', 'jquery/jquery.thread_collapse.css', 'lqt.dialogs.css' ),
 	'scripts' => array( 'lqt.js', 'js/lqt.toolbar.js', 'jquery/jquery.thread_collapse.js', 'jquery/jquery.autogrow.js' ),
-	'dependencies' => array( 'jquery.ui.dialog' ),
+	'dependencies' => array( 'jquery.ui.dialog', 'jquery.ui.droppable' ),
 	'messages' => $lqtMessages
 );


I suggest those of you who run LiquidThreads extension to check this in.

As mentioned above, http://www.translatewiki.net runs the latest code (but on MediaWiki trunk version)
Comment 1 Chad H. 2011-05-29 21:21:47 UTC
Deployed equivalent fix from r89136.
Comment 2 Krinkle 2011-06-03 08:14:25 UTC

*** This bug has been marked as a duplicate of bug 28407 ***
Comment 3 T. Gries 2011-09-24 06:51:15 UTC
Reopenend, because this functionality is broken again r97983 .
Comment 4 T. Gries 2011-09-24 06:54:23 UTC
(In reply to comment #3)
> Reopenend, because this functionality is broken again r97983 .

To be more precise: the drag and drop does not work in all cases.
Comment 5 Krinkle 2012-05-24 15:01:15 UTC
Re-duping to bug 28407.

The new breakage is due a "TypeError: Cannot read property 'length' of undefined " exception, which has broken the "Drag to new location" feature for a few months now.
Reported as bug 37085.

*** This bug has been marked as a duplicate of bug 28407 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links