Last modified: 2012-01-25 15:53:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29169 - PHP Sucks
PHP Sucks
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.20.x
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.phpsadness.com/?page=sad/11
: upstream
Depends on:
Blocks: code_quality 29079 33571
  Show dependency treegraph
 
Reported: 2011-05-27 18:00 UTC by Sam Reed (reedy)
Modified: 2012-01-25 15:53 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2011-05-27 18:00:06 UTC
See link!
Comment 1 Max Semenik 2011-05-27 18:01:08 UTC
Yeah, SUCKSFORME too.
Comment 2 Mark A. Hershberger 2011-05-27 18:04:56 UTC
Reopening.  This can only really be fixed by deploying a hiphop build.  That'll break the links on the phpsadness.com site which is what we really want.
Comment 3 Platonides 2011-05-27 20:11:13 UTC
I disagree. It can be fixed with a rewrite rule.
Comment 4 Ilmari Karonen 2011-05-27 20:20:54 UTC
That would really just address the external symptoms, not the underlying suckage.
Comment 5 Mark A. Hershberger 2011-05-27 21:14:41 UTC
(In reply to comment #4)
> That would really just address the external symptoms, not the underlying
> suckage.

php sucks in many ways.  And while the summary of this bug is vague, the first comment references only that link.  If you want other bits of PHP suck fixed, file other bugs for them and we'll make this a tracking bug.
Comment 6 Brion Vibber 2011-05-27 21:16:56 UTC
Let's do this PHP style then... resolved bogus: this is intended behavior. ;)
Comment 7 Antoine "hashar" Musso (WMF) 2012-01-24 09:28:32 UTC
PHP does not support simple maths with arrays. So I am reopening this bug.

TEST CODE:

<?php
$ab = array( 'a' => 1, 'b' => 2 );
$c  = array( 'c' => 3 );

var_export( $ab + $c );
var_export( $ab + $c - $c);
?>

RESULT:

array (
  'a' => 1,
  'b' => 2,
  'c' => 3,
)
Fatal error: Unsupported operand types in ./array.php on line 6

Call Stack:
    0.0004     645600   1. {main}() ./array.php:0

EXPECTED:
array (
  'a' => 1,
  'b' => 2,
  'c' => 3,
)
array (
  'a' => 1,
  'b' => 2,
)
Comment 8 Platonides 2012-01-24 16:57:48 UTC
It is supported, in fact it is so supported that you have 5 array_diff* functions.

As this report isn't claiming inconsistency, but lack of support, it's invalid.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links