Last modified: 2013-09-04 05:00:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29032 - Reword MediaWiki:Nosuchuser as to say "are case sensitive, except the first letter" instead of "are case sensitive"
Reword MediaWiki:Nosuchuser as to say "are case sensitive, except the first l...
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Lowest enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2011-05-18 07:37 UTC by Cyril Holweck
Modified: 2013-09-04 05:00 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Cyril Holweck 2011-05-18 07:37:55 UTC
The password recovery is to the least confusing.

I enter "cyrilh" all lowercase as username, and press "Email me new password"... the result is a message as follow, with different case "Cyrilh", and stating that it is case sensitive:

{{{
Login error
There is no user by the name "Cyrilh". User names are case sensitive. Please check your spelling, or use the link below to create a new user account.
}}}

Also notice that the "Email new password" button  with username "cholweck" will give me the same error message but not altering the case... You can easily reproduce those two scenarios to observe the bug.

I believe that my username is cyrilh, this is kind of confirmed by the fact that the login button will tell me "cholweck" user does not exist while "cyrilh" password is invalid.

I mark the bug as major as it prevents me completely from logging in.
Comment 1 Mark A. Hershberger 2011-05-20 23:19:09 UTC
I don't know if the user you're talking about is on enwiki, but http://en.wikipedia.org/wiki/User:Cyrilh shows that no user named "Cyrilh" or "cyrilh" (since, iirc, the first character is case-insensitive). Asking Chad for input.
Comment 2 Mark A. Hershberger 2011-05-23 01:33:19 UTC
Also, I think user names follow page title rules which say the first character is case insensitive, while the remaining characters are case sensitive.

Chad, can you confirm this?
Comment 3 Cyril Holweck 2011-05-23 07:53:09 UTC
I am login in from http://en.wikipedia.org/w/index.php?title=Special:UserLogin&returnto=Main_Page&campaign=ACP1

I found now my intended login (Cyril.holweck)... but what I reported is correct, the interface is confusing (it lead me to think that cyrilh was a valid user name.

I push back the bug as minor as it is actually not preventing from login in as long as one has not lost his username.
Comment 4 Chad H. 2011-05-23 12:20:31 UTC
(In reply to comment #2)
> Also, I think user names follow page title rules which say the first character
> is case insensitive, while the remaining characters are case sensitive.
> 
> Chad, can you confirm this?

Yes.
Comment 5 Cyril Holweck 2011-05-23 14:13:52 UTC
Another reason why I got confused and that is also probably a separate bug is that the user cyrilh do exist on http://fr.wikipedia.org/wiki/Utilisateur:Cyrilh

Some of the code is probably checking only on en. domain while some other parts are smarter and look cross domains and find my account on fr.
Comment 6 Dan Collins 2011-07-09 21:58:24 UTC
Looks like the only issue here is that the error message says that all characters are case sensitive, where the first is actually not. The rest is probably just SUL confusion. This is an error message wording issue, recategorizing to user interface.
Comment 7 Nemo 2012-07-25 09:32:38 UTC
Clarified summary. Note that comment 0 refers to an old version of the message. https://translatewiki.net/w/i.php?title=MediaWiki%3ANosuchuser%2Fen&diff=2502309&oldid=1478626
Comment 8 Nemo 2012-09-18 21:03:08 UTC
Gerrit change #24218.

By the way, [[mw:Manual:$wgCapitalLinks]] says the config doesn't affect usernames.
Comment 9 Nemo 2012-09-18 21:53:34 UTC
(In reply to comment #8)
> Gerrit change #24218.

WONTFIX per code review by Nikerabbit and Siebrand.
Comment 10 Nemo 2013-09-04 04:59:29 UTC
(In reply to comment #8)
> Gerrit change #24218.
> 
> By the way, [[mw:Manual:$wgCapitalLinks]] says the config doesn't affect
> usernames.

(Which is bug 26396.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links