Last modified: 2014-09-02 17:56:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26396 - Permit all lowercase (uncapitalized) usernames and user pages
Permit all lowercase (uncapitalized) usernames and user pages
Status: REOPENED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.20.x
All All
: Low enhancement with 4 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 48640 (view as bug list)
Depends on:
Blocks: 1574
  Show dependency treegraph
 
Reported: 2010-12-22 18:43 UTC by CobraSA
Modified: 2014-09-02 17:56 UTC (History)
14 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Contents of http://pastebin.com/JVxvhnhf (1.42 KB, patch)
2013-06-26 16:38 UTC, Bartosz Dziewoński
Details

Description CobraSA 2010-12-22 18:43:16 UTC
$wgCapitalLinkOverrides[ NS_USER ] = false;

is supposed to allow to have users names without capitalization.
but it doesn't work for me.

When I login as root (which is already in the database, because non capitalized user names worked in 1.12.0), it creates user Root capitalized in the database.

Please help me.
Comment 1 Chad H. 2010-12-22 18:45:17 UTC
NS_USER is hardcoded to be uppercase-only. (see MWNamespace::$alwaysCapitalizedNamespaces)

This could maybe be changed one day, but I remember there being a lot of problems when I tried.
Comment 2 CobraSA 2010-12-22 18:55:31 UTC
But in the manual it says $wgCapitalLinkOverrides can be used for User.
Comment 3 Chad H. 2010-12-22 18:59:09 UTC
Then we should update the manual :)
Comment 4 CobraSA 2010-12-22 19:29:45 UTC
where can I request the feature for lower cased user names please?
Comment 5 Roan Kattouw 2010-12-22 21:22:51 UTC
(In reply to comment #4)
> where can I request the feature for lower cased user names please?
Changed this bug to a feature request.

Note to any future implementers: this is non-trivial because it includes support for first-letter lowercase user names as well.
Comment 6 CobraSA 2010-12-22 22:03:17 UTC
Well it's no longer necessary it has been filed as a bug and should be fixed eventually.
Comment 7 CobraSA 2011-04-18 10:05:32 UTC
Who changed to enhancement? It's a bug.
Comment 8 Bawolff (Brian Wolff) 2011-04-18 16:16:22 UTC
Do you have a use case for this?
Comment 9 CobraSA 2011-04-18 18:45:18 UTC
Some titles need lower case enabled, example xXx a japanese anime
Comment 10 Bawolff (Brian Wolff) 2011-04-18 22:07:41 UTC
(In reply to comment #9)
> Some titles need lower case enabled, example xXx a japanese anime

A use case for why user names, not titles in general, need to start with a lower case letter.

Sure I suppose if you wanted to be user:xXx after the japanese anime thingy, that'd be a use case, but I wouldn't consider it a very pressing one given that the number of people who want to pick usernames of proper nouns starting with a lowercase letter is low, and you can have customizing sigs/ {{displaytitle}} for those few exceptions who do want to do that.
Comment 11 CobraSA 2011-04-19 07:31:55 UTC
Some members have a nickname similar xXx, and they don't like being XXx in my wiki, it removes the relevance of first letter not being capitalized. For example eBay23, iPod7... Yes some member actually have such nicks.
Comment 12 Dan Collins 2011-07-17 03:30:56 UTC
Recategorize, as this appears to be a feature request, not a bug.
1.16 -> 1.19-svn
Normal -> Low
Major -> Enhancement
Summary -> "Allow uncapitalized user names and User: pages"
Comment 13 Bartosz Dziewoński 2013-06-24 20:39:22 UTC
*** Bug 48640 has been marked as a duplicate of this bug. ***
Comment 14 Bartosz Dziewoński 2013-06-24 20:42:33 UTC
Copied from bug 48640 description:

<route> i've just modded 1.20.5 to permit all lowercase usernames, to do this
i've removed NS_USER from the $alwaysCapitalizedNamespaces array in
Namespace.php and i've removed calls to $wgContLang->ucfirst( $name ) in
User.php. i've created a user and it seems to have worked as i'd expect -- is
there anything i might be overlooking that could cause problems in future?

This was first allowed when the feature was implemented (r57558), then
disallowed back (r57559, r58401, r60063) with unclear comments about MediaWiki
crashing. This was back in 2009, though, and a lot might have changed.
Comment 15 elliotbrown2 2013-06-24 20:57:02 UTC
This may not be a bug for Wikimedia, but for sites using an auth extension with a forum or other user database which allows lowercase names it causes all sorts of problems (user rights not working for lcfirst users, users being told their account does not exist when trying to edit their user page). We're considering hacking the core, as annoying to keep updated as that will be, and the user from the duplicate bug above has already resorted to this.

I would like to request this is recategorized as a bug with higher importance than low since generates bugs for significant use cases, I've already run into it on three wikis I work on (one accepted the bugs, one gave up on SSO, and one is making a system which lcfirst names be shown to the wiki as ucfirst, making users names inconsistent across the site).
Comment 16 elliotbrown2 2013-06-25 15:50:23 UTC
On second thoughts, this could well be classed as a bug for Wikimedia sites as well as installations wanting to integrate users who already have lowercase first names. A new user registering with a lowercase first username will have their first experience as a new editor being mediawiki changing their name, which is kind of uncomfortable, especially for users such as myself who have used a lowercase first username on many sites and are quite fond of having it displayed the way we intend it to be. It's not an ideal first impression for an editor to have the software alter your username for unclear reasons.
Comment 17 Bawolff (Brian Wolff) 2013-06-26 05:30:45 UTC
Its extraordinarily unlikely that wikimedia sites will allow lower case usernames unless we get a compelling reason (which hasn't happened). However this is filed as a "MediaWiki" bug, not a Wikimedia one, so that is irrelevant.

>I would like to request this is recategorized as a bug with higher importance

So far the general amount of complaints don't warrant that.

>we're considering
>hacking the core, as annoying to keep updated as that will be, and the user
>from the duplicate bug above has already resorted to this.

If you're sure your patch won't break anything (and have a convincing argument that you've checked it won't cause anything to blow up), consider submitting a patch.
Comment 18 elliotbrown2 2013-06-26 16:28:45 UTC
Is allowing users to have the username they desire displayed as they are accustomed not at least a little compelling, even if not much of a priority on its own?

Even if not classed as higher priority, do you think that at least for sites trying to integrate existing users via an auth plugin not being able to display usernames correctly and opening up the risk of username conflicts (if the existing user database has two users, one with lowercase first and one with uppercase first, but otherwise same name) is be enough justification to class this as a bug? I'm not familiar with the policies around here as to what counts as a bug and feature request, but making it easier to properly support integrating mediawiki into other sites with SSO seems like something which should be a goal, and things which get in the way of that like this feel to me like bugs.

And speaking to our programmer, for now we're likely to just take the easy option and feed MW names forced to upper case, which will work but mean users with lcfirst on the rest of the sites have their usernames displayed inconsistently. Not a huge issue, but a bit of a hassle to have to set this up for a site encountering it, and a slightly uncomfortable thing to have in the long term for users who prefer lcfirst. Fixing it properly is a lower priority than quite a few other things for us right now, and if the patch ends up not being accepted it means reapplying the changes every time we update and the possibility of changes to the core making it incompatible. If we do get to this I'll post what we change here, but it'd be good to have some attention from people more familiar with MWs code to look into this and direct us towards any places other than those mentioned in the recently closed duplicate bug (he pastebinned his code changes, it expired and was not copied over, but the google cache was still live which I've re pastebinned here http://pastebin.com/JVxvhnhf ) which need changing for a way to turn this behaviour off to be added without problems.
Comment 19 Bartosz Dziewoński 2013-06-26 16:38:36 UTC
Created attachment 12648 [details]
Contents of http://pastebin.com/JVxvhnhf

Adding contents of the pastebin as an attachment just in case.
Comment 20 Bartosz Dziewoński 2013-11-13 18:24:11 UTC
*** Bug 1574 has been marked as a duplicate of this bug. ***
Comment 21 Bartosz Dziewoński 2013-11-13 18:27:55 UTC
Quoting from #wikimedia-dev short discussion about this today:

<^d> I shouldn't have enforced NS_USER to be always-uppercased when I did the namespace casing stuff years ago.
<^d> It was based on flawed assumptions at the time.
Comment 22 James Forrester 2013-11-13 18:41:27 UTC
Merging down rather than up.

*** This bug has been marked as a duplicate of bug 1574 ***
Comment 23 Vishnu Nk 2013-12-21 06:36:45 UTC
Im interested in this bug.Please assign it to me
Comment 24 Chad H. 2013-12-21 07:48:29 UTC
Unduping because it's not a dupe. Other bug is a WMF bug (which should probably be wontfixed IMHO)
Comment 25 Nemo 2013-12-21 08:50:40 UTC
(In reply to comment #23)
> Im interested in this bug.Please assign it to me

You can always submit a patch. Considering comment 1, though, for your first patch you probably don't want to start with something as hard as this.
Comment 26 Vishnu Nk 2013-12-21 13:08:26 UTC
So its not better to try with this?
Comment 27 Bawolff (Brian Wolff) 2013-12-21 17:23:48 UTC
(In reply to comment #26)
> So its not better to try with this?

You are welcome to try to fix any bug you want. The worst case scenario is that your patch gets rejected. With this bug you would have to test very carefully that you don't break anything.

The bugs on this list https://bugzilla.wikimedia.org/buglist.cgi?keywords=easy&resolution=---&list_id=261001 might be better choices as a first bug.
Comment 28 Vishnu Nk 2013-12-22 02:48:35 UTC
Thank you sir..Can you please pass on your mail id please?
Comment 29 Bawolff (Brian Wolff) 2013-12-22 04:55:53 UTC
(In reply to comment #28)
> Thank you sir..Can you please pass on your mail id please?

All bugzilla mail addresses are public. The link for the username is an email address. However for anything about the bug please just leave comments publically on the bug.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links