Last modified: 2011-04-19 16:05:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28352 - self unblock with username does not work under 1.17
self unblock with username does not work under 1.17
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
User blocking (Other open bugs)
1.17.x
All All
: Highest normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-03-31 19:29 UTC by Umherirrender
Modified: 2011-04-19 16:05 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Umherirrender 2011-03-31 19:29:50 UTC
User having user right unblockself cannot unblock himself on wmf wikis.

It works when specify the id of the block, but it does not work, when trying with the username.

The problem is in r68999:

$ip is the wrong var, you have to use $this->ip, because that reflect wpUnblockAddress, the form field with the username

Index: includes/specials/SpecialIpblocklist.php
@@ -77,7 +77,7 @@
-$user = User::newFromName( $ip );
+$user = User::newFromName( $this->ip );

Thanks.
Comment 1 Happy-melon 2011-03-31 20:41:58 UTC
I expect this is fixed in trunk; can you verify?
Comment 2 Umherirrender 2011-04-01 20:18:29 UTC
(In reply to comment #1)
> I expect this is fixed in trunk; can you verify?
Yes, it works in trunk. It is possible per Special:Block/Username, but I cannot access Special:Block directly to type in my username, but that is ok, I think.
Comment 3 Mark A. Hershberger 2011-04-19 00:10:21 UTC
Which revision has the fix so we can merge it?
Comment 4 Happy-melon 2011-04-19 10:07:20 UTC
You'll need most of the blocking frontend rewrite, that's r83786 and friends, r83825, r83855, r83909, and most of their follow-ups.  You probably won't need the backend stuff I did afterwards.  I have no idea which of these contains the fix, and it almost certainly won't work without the others anyway.  

It's very probably easier to do a quick hackfix in the REL1_17 branch and worry about reviewing all this for 1.18.
Comment 5 Mark A. Hershberger 2011-04-19 15:30:22 UTC
Can you do the quick fix for 1.17?  We're already looking at the code for 1.18, so we'll make sure the rewrite is included there.
Comment 6 Happy-melon 2011-04-19 16:05:22 UTC
Fixed in r86409.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links