Last modified: 2011-03-01 23:56:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27761 - Links to page with ux don't display in Esperanto Wikipedia (eo.wikipedia.org)
Links to page with ux don't display in Esperanto Wikipedia (eo.wikipedia.org)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.17.x
All All
: High critical (vote)
: ---
Assigned To: Brion Vibber
http://eo.wikipedia.org/wiki/Premeaux...
: code-update-regression
Depends on:
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-27 13:51 UTC by Arno Lagrange
Modified: 2011-03-01 23:56 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Arno Lagrange 2011-02-27 13:51:43 UTC
Trying to open a page such http://eo.wikipedia.org/wiki/Premeaux-Prissey ([[:eo:Premeaux-Prissey]] ) we now get "Internal error
Redirect loop detected!"
It's in relation with the ux -> ŭ magic system which didn't more work just in the day when 1.17 was applied to eo.wp The problem what appeared in this day has been fixed, but now we have found an other one. Such problems had exist in the past (few years ago) and already had been fixed in this time. (Ask Brion Vibber about: he perfectly knows the matter).
Comment 1 Chad H. 2011-03-01 17:48:11 UTC
Bumping priority on this by a lot. This is also a +code-update-regression.

Switching to lang converter (and adding CC), he made a bunch of changes to this in 1.17.
Comment 2 MZMcBride 2011-03-01 18:20:37 UTC
This likely isn't LanguageConverter-related. Updating component to "General/Unknown."
Comment 3 Brion Vibber 2011-03-01 21:00:14 UTC
Taking a peek. Possibly due to changes in charset conversion or canonical title redirection.
Comment 4 Brion Vibber 2011-03-01 21:14:20 UTC
r70871 changed how titles are extracted, probably not realizing that WebRequest::getText() can perform character set conversion.
Comment 5 Brion Vibber 2011-03-01 21:21:00 UTC
Fixed on trunk in r83046: needs merge to 1.17wmf1 and deployment.
Comment 6 Arno Lagrange 2011-03-01 23:56:43 UTC
Ŝajnas riparita ! Dankon Briono ! 
Looks like fixed ! Thanks to Brion !

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links