Last modified: 2012-08-04 20:48:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27731 - Creating Template page show database error for PostgreSQL 9.0.1
Creating Template page show database error for PostgreSQL 9.0.1
Status: RESOLVED DUPLICATE of bug 27380
Product: MediaWiki extensions
Classification: Unclassified
SemanticForms (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Yaron Koren
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2011-02-26 02:38 UTC by Anton Kochkov
Modified: 2012-08-04 20:48 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Anton Kochkov 2011-02-26 02:38:11 UTC
A database error has occurred
I'm have MediaWiki 1.16.0, PostgreSQL 9.0.1, latest (from svn SematicWiki/SemanticForms)

Query: DELETE FROM smw_tmp_unusedprops USING smw_tmp_unusedprops INNER JOIN smw_rels2 INNER JOIN smw_ids ON p_id=smw_id AND title=smw_title AND smw_iw=''
Function: SMW::getUnusedPropertySubjects
Error: 1 ERROR: syntax error at end of input
LINE 1: ...OIN smw_ids ON p_id=smw_id AND title=smw_title AND smw_iw=''
^
Backtrace:
#0 /usr/home/droid-dev/www/includes/db/Database.php(538): DatabasePostgres->reportQueryError('ERROR: syntax ...', 1, 'DELETE FROM smw...', 'SMW::getUnusedP...', false)
#1 /usr/home/droid-dev/www/extensions/SemanticMediaWiki/includes/storage/SMW_SQLStore2.php(1099): DatabaseBase->query('DELETE FROM smw...', 'SMW::getUnusedP...')
#2 /usr/home/droid-dev/www/extensions/SemanticForms/specials/SF_CreateTemplate.php(43): SMWSQLStore2->getUnusedPropertiesSpecial(Object(SMWRequestOptions))
#3 /usr/home/droid-dev/www/extensions/SemanticForms/specials/SF_CreateTemplate.php(99): SFCreateTemplate::getAllPropertyNames()
#4 /usr/home/droid-dev/www/extensions/SemanticForms/specials/SF_CreateTemplate.php(27): SFCreateTemplate::printCreateTemplateForm()
#5 /usr/home/droid-dev/www/includes/SpecialPage.php(559): SFCreateTemplate->execute(NULL)
#6 /usr/home/droid-dev/www/includes/Wiki.php(254): SpecialPage::executePath(Object(Title))
#7 /usr/home/droid-dev/www/includes/Wiki.php(64): MediaWiki->handleSpecialCases(Object(Title), Object(OutputPage), Object(WebRequest))
#8 /usr/home/droid-dev/www/index.php(117): MediaWiki->performRequestForTitle(Object(Title), NULL, Object(OutputPage), Object(User), Object(WebRequest))
#9 {main}
Comment 1 Yaron Koren 2011-02-27 15:28:39 UTC
Hi - do you see this same error when you go to the page Special:UnusedProperties? If so, it's actually a bug in Semantic MediaWiki.
Comment 2 Anton Kochkov 2011-02-27 15:52:46 UTC
Yes. Same error on Special:UnusedProperties
Comment 3 Yaron Koren 2011-02-27 16:00:32 UTC
Okay - I'm marking this as a duplicate of bug 27380.

*** This bug has been marked as a duplicate of bug 27380 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links