Last modified: 2012-04-16 09:15:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27477 - [Regression!] ImageInfo API query returns descriptionUrl = false if file comes from local repository
[Regression!] ImageInfo API query returns descriptionUrl = false if file come...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Bryan Tong Minh
: code-update-regression
: 27749 (view as bug list)
Depends on:
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-16 22:42 UTC by Lupo
Modified: 2012-04-16 09:15 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Lupo 2011-02-16 22:42:02 UTC
Compare the output of the two following queries:

http://commons.wikimedia.org/w/api.php?action=query&titles=File:Albert%20Einstein%20Head.jpg&prop=imageinfo&iiprop=url&format=jsonfm

http://en.wikipedia.org/w/api.php?action=query&titles=File:Albert%20Einstein%20Head.jpg&prop=imageinfo&iiprop=url&format=jsonfm

The file resides at the Commons. When the query is run at the Commons, descriptionurl is false; when run at the English Wikipedia, it is set correctly to the file description page at the Commons.

Trying the same query for a file that actually is at en-WP:

http://en.wikipedia.org/w/api.php?action=query&titles=File:Kouprey%20at%20Vincennes%20Zoo%20in%20Paris%20by%20Georges%20Broihanne%201937.jpg&prop=imageinfo&iiprop=url&format=jsonfm

Again descriptionurl is false.
Comment 1 Sam Reed (reedy) 2011-02-16 22:48:37 UTC
To me, in the code, it looks to be done purposefully, but I can't swear to it.

Hopefully Bryan can confirm either way, and fix if it is an issue.
Comment 2 Lupo 2011-02-17 06:42:18 UTC
If it's intended behavior that the descriptionurl is always false for local files, fine by me, but then please document it. I just reported it because prior to the switch to 1.17 at the Commons, it was set.
Comment 3 Bryan Tong Minh 2011-02-17 08:32:04 UTC
This is a bug.
Comment 4 Bryan Tong Minh 2011-02-17 09:02:15 UTC
Most likely caused by r68897, but I can't reproduce it locally... interesting.
Comment 5 Bryan Tong Minh 2011-02-28 18:39:49 UTC
*** Bug 27749 has been marked as a duplicate of this bug. ***
Comment 6 Krinkle 2011-02-28 22:50:43 UTC
(In reply to comment #5)
> *** Bug 27749 has been marked as a duplicate of this bug. ***

Adding the same tags/blockers from the dupe-marked bug bug 27749
Comment 7 Bryan Tong Minh 2011-03-02 19:58:32 UTC
I'm reading the code from 1.16wmf4 and I wonder how this could have ever worked.
Comment 8 Bryan Tong Minh 2011-03-02 20:35:39 UTC
r70296 is to blame
Comment 9 Bryan Tong Minh 2011-03-02 21:09:42 UTC
Fixed in r83114.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links