Last modified: 2011-02-19 10:26:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27454 - <pages> tag from ProofreadPage extension broken on enwikisource since 1.17 upgrade
<pages> tag from ProofreadPage extension broken on enwikisource since 1.17 up...
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
: code-update-regression
Depends on:
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-16 13:06 UTC by Adrian Frith
Modified: 2011-02-19 10:26 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Adrian Frith 2011-02-16 13:06:28 UTC
Since today's upgrade to 1.17, the <pages> tag[1] from the Proofread Page extension[2] has been partly broken. The "fromsection" and "tosection" parameters to that tag[3] are supposed to ensure that only specfic labelled sections are transcluded from the first and last pages (respectively) in the range of pages transcluded. (These are "sections" as defined by Labelled Section Transclusion.[4])

For concrete examples see [5,6]; in each case the end of the previous article and the beginning of the next article are included because the whole page is being transcluded rather than only the labelled sections specified.

This definitely only started happening today. It is a show-stopper bug for Wikisource, affecting as it does probably thousands, and certainly many hundreds, of works.

[1] http://en.wikisource.org/wiki/Help:Proofread#Full-page_transclusion
[2] http://www.mediawiki.org/wiki/Extension:Proofread_Page
[3] http://en.wikisource.org/wiki/Help:Proofread#Combination_multipage_and_partial_transclusion
[4] http://www.mediawiki.org/wiki/Extension:Labeled_Section_Transclusion
[5] http://en.wikisource.org/wiki/1911_Encyclop%C3%A6dia_Britannica/Cape_Town
[6] http://en.wikisource.org/wiki/Dawkins,_James_%28DNB01%29
Comment 1 billinghurst 2011-02-16 14:49:01 UTC
It would seem to be related to parts of ProofreadPage as normal #lst tests work fine. Catrope had a look and suspects that it may be somewhere in r:73215
Comment 2 billinghurst 2011-02-16 14:49:54 UTC
(In reply to comment #1)
> It would seem to be related to parts of ProofreadPage as normal #lst tests work
> fine. Catrope had a look and suspects that it may be somewhere in r:73215

urk that didn't work

https://secure.wikimedia.org/wikipedia/mediawiki/wiki/Special:Code/MediaWiki/73215
Comment 3 ThomasV 2011-02-18 15:42:13 UTC
this should fix it : 
http://www.mediawiki.org/wiki/Special:Code/MediaWiki/82404
Comment 4 Adrian Frith 2011-02-19 10:26:03 UTC
Any idea when the fix will be applied to en.wikisource?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links