Last modified: 2011-02-13 01:33:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27372 - Bugs in debug mode on simple wikipedia
Bugs in debug mode on simple wikipedia
Status: RESOLVED DUPLICATE of bug 27321
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
1.17.x
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://simple.wikipedia.org/wiki/Main...
:
Depends on:
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-12 22:03 UTC by Nux
Modified: 2011-02-13 01:33 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nux 2011-02-12 22:03:04 UTC
There is a problem with collapsible tabs and collapsible nav. What's interesting is that they show up only when debug is true.

Putting this exact errors aside - is it an expected behaviour that they weren't shown without debugging mode? Are all scripts in try catch or something?

Or maybe this is some weird problem with RL?
Comment 1 Roan Kattouw 2011-02-12 22:04:55 UTC
(In reply to comment #0)
> There is a problem with collapsible tabs and collapsible nav. What's
> interesting is that they show up only when debug is true.
> 
> Putting this exact errors aside - is it an expected behaviour that they weren't
> shown without debugging mode? Are all scripts in try catch or something?
> 
> Or maybe this is some weird problem with RL?
It's probably a JS error. In debug mode, scripts aren't combined, so I guess a JS error in one script doesn't stop another script in that case.
Comment 2 Krinkle 2011-02-13 01:33:43 UTC
This was indeed caused by some modules not being loaded in debug mode.

This has been fixed now and is deployed on test2.wikipedia.org.
It will soon be live on other wikis as well (or perhaps already is)

*** This bug has been marked as a duplicate of bug 27321 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links