Last modified: 2011-02-18 01:21:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27368 - 1.17 deployment enables enhanced toolbar even when disabled in prefs
1.17 deployment enables enhanced toolbar even when disabled in prefs
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Roan Kattouw
http://en.wikinews.org
:
Depends on: 27471
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-12 21:04 UTC by Douglas Gardner
Modified: 2011-02-18 01:21 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Douglas Gardner 2011-02-12 21:04:39 UTC
[[n:User:Dendodge]] has reported that the enhanced toolbar is shown on edit pages even when 'Enable enhanced editing toolbar', in the 'Editing' section of Special:Preferences is set to false.

I have been able to reproduce this bug on Chromium and Firefox.
Comment 1 Roan Kattouw 2011-02-14 21:17:01 UTC
(In reply to comment #0)
> [[n:User:Dendodge]] has reported that the enhanced toolbar is shown on edit
> pages even when 'Enable enhanced editing toolbar', in the 'Editing' section of
> Special:Preferences is set to false.
> 
> I have been able to reproduce this bug on Chromium and Firefox.
On which wiki?
Comment 2 Douglas Gardner 2011-02-14 21:35:08 UTC
enwikinews
Comment 3 Trevor Parscal 2011-02-14 21:43:06 UTC
I can't reproduce either. I'm going to close it unless someone can prove it's happening.
Comment 4 Roan Kattouw 2011-02-14 21:53:32 UTC
Wrong bug? I did find a database issue that's causing this. Reopening.
Comment 5 Roan Kattouw 2011-02-14 22:17:54 UTC
This seems to be caused by an empty value for the usebetatoolbar preferences for this user. This affects other preferences and other users as well, probably on all wikis. Either Tim or I will write a script to fix all of these and run it.
Comment 6 Mark A. Hershberger 2011-02-15 19:48:38 UTC
Moving to something to be fixed post (or even pre?) deployment.  Since it seems to be DB, and not code, related.
Comment 7 Roan Kattouw 2011-02-16 21:12:09 UTC
This is caused by bug 27471
Comment 8 Roan Kattouw 2011-02-17 23:26:58 UTC
Should be fixed now, please confirm.
Comment 9 Douglas Gardner 2011-02-18 01:21:34 UTC
Works for me. I'll close this & reopen if other users report problems.

Thanks

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links