Last modified: 2011-02-19 08:02:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27053 - Installer creates users with the name "{$wgDBuser}"
Installer creates users with the name "{$wgDBuser}"
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.18.x
All All
: High blocker (vote)
: ---
Assigned To: Chad H.
:
Depends on:
Blocks: 26676
  Show dependency treegraph
 
Reported: 2011-01-30 22:50 UTC by Daniel Friesen
Modified: 2011-02-19 08:02 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Daniel Friesen 2011-01-30 22:50:24 UTC
Looks like the installer is broken again. When having MW create a db user itself it goes and creates users with the name "{$wgDBuser}" now.

It was previously broken in a different way, I fixed it... now it's broken again... don't feel like fixing it myself right now.
Comment 1 Mark A. Hershberger 2011-01-31 03:00:12 UTC
marking as 1.17 blocker for now till we ensure that it isn't.
Comment 2 Mark A. Hershberger 2011-02-02 19:49:09 UTC
Removing 1.17 blocker
Comment 3 Chad H. 2011-02-10 16:47:49 UTC
Confirmed, taking bug. Re-adding blocker status.
Comment 4 Max Semenik 2011-02-10 19:20:08 UTC
The following patch fixes the username, though I'm still unable to log in with that account.

Index: MysqlInstaller.php
===================================================================
--- MysqlInstaller.php	(revision 81910)
+++ MysqlInstaller.php	(working copy)
@@ -463,6 +463,8 @@
 	public function getSchemaVars() {
 		return array(
 			'wgDBTableOptions' => $this->getTableOptions(),
+			'wgDBuser' => $this->getVar( 'wgDBuser' ),
+			'wgDBpassword' => $this->getVar( 'wgDBpassword' ),
 		);
 	}
Comment 5 Max Semenik 2011-02-19 08:02:37 UTC
Fixed in r82439.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links