Last modified: 2011-02-08 21:56:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26757 - What leaves here ? (to acompany What links here?)
What leaves here ? (to acompany What links here?)
Status: RESOLVED DUPLICATE of bug 12907
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.18.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-16 15:06 UTC by Krinkle
Modified: 2011-02-08 21:56 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot of http://meta.wikimedia.org/wiki/User:Krinkle/Tools/WhatLeavesHere (168.59 KB, image/png)
2011-01-16 15:06 UTC, Krinkle
Details

Description Krinkle 2011-01-16 15:06:25 UTC
Created attachment 7996 [details]
Screenshot of http://meta.wikimedia.org/wiki/User:Krinkle/Tools/WhatLeavesHere

During the 2011 Amsterdam Hackathon ([[w:nl:chapter:Hackathon 2011]]) I showed Roan my JavaScript gadget for "What leaves here". 

"Isn't that in the core UI, like in the API ?" was something I heard, so filing it here.

keywords:
Filter
* Source parameter (like WhatLinksHere's "target" parameter)
* Namespace parameter (eg. only outgoing links to the X namespace, like WhatLinksHere's only incominglinks from the X namespace)
* Pagination (should be seperate per kind of outgoing like (Links, External links, Categories)
* Limit parameter

Output sketch:

== Internal links ==
Linkfilter: "Hide transclusions | Hide links | Hide redirects | Hide interwiki links"
List with pagelinks, imagelinks, transclusions and (new in 1.17) iw_links (indicating the kind of link in parentheses) like:
* [[File:Acap.svg]] (image link) (← leaves)
* [[w:Foobar]] (← leaves)

View (previous 50 | next 50) (20 | 50 | 100 | 250 | 500)

== External links ==
list with external links
* irc://irc.freenode.net/wikimedia-commons (← linksearch)

View (previous 50 | next 50) (20 | 50 | 100 | 250 | 500)

== Categories ==
List with categories
* Category:RTRC users (← leaves)

View (previous 50 | next 50) (20 | 50 | 100 | 250 | 500)


All this information is available with high effeciency, as also through the API.

Attached:
* Screenshot of my JavaScript gadget. Although it doesn't have all the features that it could have when done in core, the basic concept works
See also http://meta.wikimedia.org/wiki/User:Krinkle/Tools/WhatLeavesHere
Comment 1 Krinkle 2011-01-16 15:07:08 UTC
LInkfix: [[nl:chapter:Hackathon 2011]]
Comment 2 Sam Reed (reedy) 2011-01-16 21:35:48 UTC
(In reply to comment #0)
> Created attachment 7996 [details]
> Screenshot of http://meta.wikimedia.org/wiki/User:Krinkle/Tools/WhatLeavesHere
> 
> During the 2011 Amsterdam Hackathon ([[w:nl:chapter:Hackathon 2011]]) I showed
> Roan my JavaScript gadget for "What leaves here". 
> 
> "Isn't that in the core UI, like in the API ?" was something I heard, so filing
> it here.
> 

I was thinking the exact same..
Comment 3 Sam Reed (reedy) 2011-01-16 23:49:49 UTC
BTW, Links on page, IMHO "sounds" better
Comment 4 Krinkle 2011-01-17 02:58:13 UTC
Since Roan has a lot on the agenda already and I read up on the new stuff in the SpecialPage class since 1.15 during the Hackathon –  I'll take a stab at this myself.
Comment 5 Krinkle 2011-01-17 14:22:39 UTC
It's been requested in 2008 (thanks ^demon)

*** This bug has been marked as a duplicate of bug 12907 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links