Last modified: 2012-09-27 01:11:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26035 - make sure 'empty' sections are also empty on text browsers
make sure 'empty' sections are also empty on text browsers
Status: RESOLVED DUPLICATE of bug 23026
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.17.x
All All
: Low minor (vote)
: ---
Assigned To: Trevor Parscal
: accessibility
Depends on:
Blocks: 367
  Show dependency treegraph
 
Reported: 2010-11-21 06:52 UTC by Dan Jacobson
Modified: 2012-09-27 01:11 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2010-11-21 06:52:04 UTC
Fine with me if you want to make empty sections (Bug #23026). Go right
ahead. But please please please do it a cleaner way, making sure that
they don't still inadvertently show up visible in text browsers!!

$ w3m -dump http://abj.jidanni.org/index.php?title=Special:Specialpages | grep -C 7 Views

Namespaces

  • Special page

Variants

Views

Actions

Search

[                    ] [Go] [Search]

$ GET http://abj.jidanni.org/index.php?title=Special:Specialpages | grep -A 1 empty
<div id="p-variants" class="vectorMenu emptyPortlet">
		<h5><span>Variants</span><a href="#"></a></h5>
--
<div id="p-views" class="vectorTabs emptyPortlet">
	<h5>Views</h5>
--
<div id="p-cactions" class="vectorMenu emptyPortlet">
	<h5><span>Actions</span><a href="#"></a></h5>

If you can't do it a cleaner way, then don't do it in the first place.
We never had such a problem with other skins.

If it is not to be shown to the general public, then don't show it to
text browsers users either, please.
Comment 1 Dan Jacobson 2010-11-21 06:54:17 UTC
Use Alt V Y N (View -> Page Style -> No style) to see the bug in Firefox.
Comment 2 Christopher Yeleighton 2011-06-15 12:23:39 UTC
empty lists are not valid per XHTML.

<URL: http://www.mediawiki.org/wiki/MediaWiki >

Line 214, Column 10: end tag for "ul" which is not finished

(at least one list item must be present)
Comment 3 Roan Kattouw 2011-06-15 14:13:49 UTC
(In reply to comment #2)
> empty lists are not valid per XHTML.
> 
> <URL: http://www.mediawiki.org/wiki/MediaWiki >
> 
> Line 214, Column 10: end tag for "ul" which is not finished
> 
> (at least one list item must be present)
We know, and we don't care. This restriction in XHTML is stupid, and was removed in HTML5. See bug 24500 comment 7 for the full argument for keeping these empty lists.
Comment 4 Krinkle 2011-06-20 12:30:08 UTC

*** This bug has been marked as a duplicate of bug 24500 ***
Comment 5 Krinkle 2011-06-20 12:33:38 UTC

*** This bug has been marked as a duplicate of bug 23026 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links