Last modified: 2012-09-27 01:10:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23026 - Don't make empty sections in the first place
Don't make empty sections in the first place
Status: RESOLVED DUPLICATE of bug 24500
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.17.x
All All
: Lowest enhancement (vote)
: ---
Assigned To: Trevor Parscal
http://transgender-taiwan.org/index.p...
:
: 25210 25366 26035 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 03:05 UTC by Dan Jacobson
Modified: 2012-09-27 01:10 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2010-04-02 03:05:16 UTC
Note the empty Variants section if one turns off stylesheets with
e.g., Firefox's Views->Page style.

If there are no variants, this section shouldn't be created in the
first place.

<!-- 1 -->
<div id="p-variants" class="vectorMenu emptyPortlet">
	<h5><span>Variants</span><a href="#"></a></h5>
	<div class="menu">
			</div>
</div>

<!-- /1 -->
Comment 1 Trevor Parscal 2010-04-21 23:08:50 UTC
What if someone wants to add them dynamically. That was the whole idea of leaving the UL there in the first place, but fine - fair point that it's invalid HTML. It's a balancing act at this point between what it is on load and what it may become afterward.
Comment 2 Krinkle 2011-06-20 12:31:10 UTC
*** Bug 24500 has been marked as a duplicate of this bug. ***
Comment 3 Krinkle 2011-06-20 12:32:38 UTC
*** Bug 25210 has been marked as a duplicate of this bug. ***
Comment 4 Krinkle 2011-06-20 12:33:03 UTC
*** Bug 25366 has been marked as a duplicate of this bug. ***
Comment 5 Krinkle 2011-06-20 12:33:38 UTC
*** Bug 26035 has been marked as a duplicate of this bug. ***
Comment 6 Aryeh Gregor (not reading bugmail, please e-mail directly) 2011-06-20 22:46:36 UTC
Making bug 24500 the bug for this because there's more discussion there.

*** This bug has been marked as a duplicate of bug 24500 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links