Last modified: 2011-11-30 00:25:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24204 - Problem with external link arrow in rtl languages
Problem with external link arrow in rtl languages
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
https://bugs.webkit.org/show_bug.cgi?...
: i18n, upstream
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2010-07-01 07:14 UTC by Percy Mett
Modified: 2011-11-30 00:25 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Percy Mett 2010-07-01 07:14:21 UTC
There is a problem with the arrow which appears with a link to an external web page.
When the text wraps, the arrow appears in the wrong place, overlaying the text.

See, for example,

http://yi.wikipedia.org/wiki/%D7%B0%D7%99%D7%A7%D7%99%D7%A4%D6%BC%D7%A2%D7%93%D7%99%D7%A2:%D7%A0%D7%99%D7%A6%D7%9C%D7%A2%D7%9B%D7%A7%D7%99%D7%99%D7%98%D6%BE%D7%90%D7%99%D7%A0%D7%99%D7%A6%D7%99%D7%90%D7%98%D7%99%D7%95%D7%95/%D7%A0%D7%99%D7%99%D7%A2_%D7%90%D7%99%D7%99%D7%92%D7%A0%D7%A7%D7%99%D7%99%D7%98%D7%9F
Comment 1 Roan Kattouw 2010-07-01 08:02:27 UTC
That link looks good to me.
Comment 2 Percy Mett 2010-07-01 10:23:57 UTC
Change the width of the the window so that the text wraps.
Comment 3 Derk-Jan Hartman 2010-07-01 11:24:15 UTC
Which browsers + versions are you encountering this problem with ?
Comment 4 Roan Kattouw 2010-07-01 19:12:23 UTC
Not seeing it, even with a narrower window, on Firefox 3.6. I need specific browser information to be able to debug this.
Comment 5 Percy Mett 2010-07-01 22:28:13 UTC
Sorry, I forgot to check it with Firefox. FF 3.6 handles this OK.
But Safari, Chrome and Opera all overlay the arrow when the link text is wrapped.
Comment 6 Derk-Jan Hartman 2010-07-05 22:26:24 UTC
I can confirm this behavior. Seems like a bug in Opera and Safari to me though....
Comment 7 Derk-Jan Hartman 2010-07-31 17:12:35 UTC
Reported this issue for Webkit. https://bugs.webkit.org/show_bug.cgi?id=43302
Comment 8 Siebrand Mazeland 2010-08-29 11:54:36 UTC
Setting this to page rendering category (from i18n).

The report in comment 7 was a duplicate of https://bugs.webkit.org/show_bug.cgi?id=9272 (that issues does not appear to have gotten love since it was reported in June 2006).
Comment 9 Mark A. Hershberger 2011-05-15 17:25:48 UTC
Resolving later since this is an upstream bug that we have no control over.
Comment 10 Mark A. Hershberger 2011-05-15 18:48:14 UTC
Oh, looks like upstream has closed the dupe.  Could someone verify that this is solved?
Comment 11 Amir E. Aharoni 2011-05-15 23:53:57 UTC
It works well on Google Chrome.
Comment 12 Percy Mett 2011-05-16 11:47:17 UTC
(In reply to comment #11)
> It works well on Google Chrome.

Indeed it does.

But the problem remains on both Safari and Opera.
Comment 13 Diederik van Liere 2011-11-30 00:25:21 UTC
I tested this with Safari 5.1.2 and it works, so I am going mark this bug as WORKSFORME. Even if it is still a problem in Opera then it should not be labeled LATER because LATER suggests that we need to do something while this is obviously a browser issue.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links