Last modified: 2012-07-25 10:09:38 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23223 - Establish Wikimedia branch office in Germany
Establish Wikimedia branch office in Germany
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Highest blocker with 5 votes (vote)
: ---
Assigned To: Ævar Arnfjörð Bjarmason
: accessibility, performance, shell, tracking, upstream
Depends on:
Blocks: tracking 29079
  Show dependency treegraph
 
Reported: 2010-04-17 10:29 UTC by Chad H.
Modified: 2012-07-25 10:09 UTC (History)
35 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Quick fix (206 bytes, patch)
2010-04-17 10:38 UTC, Svip
Details

Description Chad H. 2010-04-17 10:29:44 UTC
Currently, due to Ævar setting off Eyjafjallajökull, most of the people attending the 2010 Wikimedia conference in Berlin are stranded.

Need a patch, asap.
Comment 1 Happy-melon 2010-04-17 10:31:58 UTC
Well, guess you'd better get to work then...  :-P
Comment 2 p858snake 2010-04-17 10:32:55 UTC
Do we really want to solve this.... looks like a INVALID or WONTFIX tbh....
Comment 3 Andrew Garrett 2010-04-17 10:35:54 UTC
Reassigning to Ævar.
Comment 4 Svip 2010-04-17 10:38:54 UTC
Created attachment 7301 [details]
Quick fix

Here is a quick fix.  Please apply through time loop.
Comment 5 Chad H. 2010-04-17 10:39:44 UTC
Adding following keywords:

+accessibility: We cannot currently access our flights home
+upstream: The volcano needs fixing first, suggest filing a bug with Iceland.
Comment 6 Max Semenik 2010-04-17 10:43:29 UTC
Everything goes on according to masterplan. When the developers are out of their homes, their productivity increases, even Brion resumed committing. Return to work, slaves!
Comment 7 Sam Reed (reedy) 2010-04-17 10:48:03 UTC
Chad, you didn't add the keywords!
Comment 8 Victor Vasiliev 2010-04-17 10:54:25 UTC
Wrong venue. Use [[WP:ANI]], [[WP:RFC/U]] or even [[WP:RFAR]] to impose sanctions against the volcano.
Comment 9 Chad H. 2010-04-17 11:02:45 UTC
(In reply to comment #8)
> Wrong venue. Use [[WP:ANI]], [[WP:RFC/U]] or even [[WP:RFAR]] to impose
> sanctions against the volcano.

I disagree, this is clearly outside of the English Wikipedia's scope. REOPENING.
Comment 10 Sam Reed (reedy) 2010-04-17 11:04:32 UTC
http://is.wikipedia.org/wiki/Hj%C3%A1lp:Efnisyfirlit

Not sure where to go from there.
Comment 11 Svip 2010-04-17 11:07:05 UTC
(In reply to comment #10)
> http://is.wikipedia.org/wiki/Hj%C3%A1lp:Efnisyfirlit
> 
> Not sure where to go from there.

We are in need of a decryption patch too!
Comment 12 Victor Vasiliev 2010-04-17 11:36:26 UTC
http://meta.wikimedia.org/wiki/Special:CentralAuth/Eyjafjallaj%C3%B6kull - needs steward attention.
Comment 13 Milos Rancic 2010-04-17 17:00:29 UTC
Who should be blocked?
Comment 14 Ariel T. Glenn 2010-04-17 17:06:03 UTC
Actually it's been nice and quiet in the office lately...
Comment 15 Svip 2010-04-17 19:08:07 UTC
Cannot replicate bug.

Please check if it is not an issue regarding your local system.
Comment 16 Sam Reed (reedy) 2010-04-17 19:09:23 UTC
I know enough people who can easily replicate this bug.
Comment 17 Svip 2010-04-17 19:12:09 UTC
Maybe they are using the same distribution.

I suggest updating their OS to its latest version.  This issue seems to be more appropriate for a patch at air traffic regulations or weather in general.  I already provided with a quick and dirty fix, but that requires root access to the world.
Comment 18 Bryan Tong Minh 2010-04-17 19:14:07 UTC
Suggest INVALID; I don't want to get out of Europe. 

I also would like to point out that the UK technically is still part of Europe and therefore the bug summary needs tweaking.
Comment 19 Sam Reed (reedy) 2010-04-17 19:16:20 UTC
Mainland? :P
Comment 20 Svip 2010-04-17 19:18:21 UTC
From my understanding, the UK is also hit.  In addition, Spain, which is also part of Europe is not hit.
Comment 21 OverlordQ 2010-04-17 19:36:41 UTC
Suitable workaround is: apt-get install boats

Will take longer then by plane, but is only workable solution while $wgExplodingVolcanoes = true.
Comment 22 Svip 2010-04-17 19:40:02 UTC
apt-get requires funds.  I recommend /usr/transport/boats >> /home/wikimedia/developers
Comment 23 Siebrand Mazeland 2010-04-17 19:42:43 UTC
Proposed fix: dig.
Comment 24 Svip 2010-04-17 19:45:58 UTC
(In reply to comment #23)
> Proposed fix: dig.

Issue:  China is not on the other side of Europe.
Fix:  Bring wetsuits.
Comment 25 Thor Malmjursson 2010-04-17 19:49:01 UTC
I agree with OverlordQ, since $wgExplodingVolcanoes = true, the situation
$wgCantFly also remains true.

I recommend all those for whom $wgCantFly applies, reroute to .gr via rail to
disable $wgCantFly.  For .uk, reroute via rail to .nl, set $wgGetFerry
(From.amsterdam), and urpmi boat-home from there.

It appears the $wgExplodingVolcanoes situation won't resolve, so I'm setting to
LATER as a resolution for now.
Comment 26 Gurch 2010-04-17 20:37:27 UTC
Not a bug; this behavior is by design.

--God
Comment 27 Church of emacs 2010-04-17 20:51:37 UTC
As I arrived in Munich today, I think this should be RESOLVED WORKSFORME. ;-)

RFC 2549 describes the process of delivering data via avian carriers. Perhaps it's possible to use a dirty hack and use that RFC for transporting conference attendees?
Comment 28 Ariel T. Glenn 2010-04-17 20:56:27 UTC
This design "feature" needs to be reexamined by the usability team.  I suspect they will have some changes to recommend.
Comment 29 Bawolff (Brian Wolff) 2010-04-17 20:57:28 UTC
(In reply to comment #27)
> As I arrived in Munich today, I think this should be RESOLVED WORKSFORME. ;-)
> 
> RFC 2549 describes the process of delivering data via avian carriers. Perhaps
> it's possible to use a dirty hack and use that RFC for transporting conference
> attendees?

RFC 1437 describes some issues relating to transporting people over IP. I think its doable.
Comment 30 Maarten Dammers 2010-04-17 20:58:27 UTC
I need to get back into Europe!
Should I create another bug and slave it to this one? :P
Comment 31 Sam Reed (reedy) 2010-04-17 20:59:18 UTC
Waiting on upstream changes
Comment 32 Church of emacs 2010-04-17 21:02:16 UTC
Can't we mark it as RESOLVED LATER? If you ask me, this bug will be obsolete by the time the next MediaWiki version is released.
Also, this doesn't seem to be a usability issue, but something on the back-end. Changing the painting of the airplane won't fix the problem.
Comment 33 Roan Kattouw 2010-04-17 21:04:27 UTC
(In reply to comment #32)
> Can't we mark it as RESOLVED LATER? If you ask me, this bug will be obsolete by
> the time the next MediaWiki version is released.
> Also, this doesn't seem to be a usability issue, but something on the back-end.
> Changing the painting of the airplane won't fix the problem.
There was a usability issue upstream: the "set off vulcano" button was placed next to the light switch.
Comment 34 Svip 2010-04-17 21:30:03 UTC
(In reply to comment #33)
> (In reply to comment #32)
> > Can't we mark it as RESOLVED LATER? If you ask me, this bug will be obsolete by
> > the time the next MediaWiki version is released.
> > Also, this doesn't seem to be a usability issue, but something on the back-end.
> > Changing the painting of the airplane won't fix the problem.
> There was a usability issue upstream: the "set off vulcano" button was placed
> next to the light switch.

it must be god error
Comment 35 Victor Vasiliev 2010-04-17 22:07:24 UTC
Okay, guys, looks like we have no other options.

To solve this bug we need to do a parser rewrite.
Comment 36 Ryan Schmidt 2010-04-17 22:11:28 UTC
(In reply to comment #35)
> Okay, guys, looks like we have no other options.
> 
> To solve this bug we need to do a parser rewrite.

Has anyone tried blanking it yet? That usually fixes things.

After all, without a parser, the Sky object can't detect $wgExplodingVolcanoes and thus will leave $wgCantFly in its default state of false, allowing the stranded people to simply take airplanes as previously scheduled.
Comment 37 Sam Reed (reedy) 2010-04-17 22:14:42 UTC
(In reply to comment #36)
> (In reply to comment #35)
> > Okay, guys, looks like we have no other options.
> > 
> > To solve this bug we need to do a parser rewrite.
> 
> Has anyone tried blanking it yet? That usually fixes things.
> 

Gentlemen,

Have we tried turning it off and on again?
Comment 38 Sam Reed (reedy) 2010-04-17 22:18:16 UTC
(In reply to comment #35)
> Okay, guys, looks like we have no other options.
> 
> To solve this bug we need to do a parser rewrite.

After previous discussion with Brion, ^demon and Avar, lolcode would be the language of choice
Comment 39 Siebrand Mazeland 2010-04-17 22:24:18 UTC
I don't mean to be nitpicking here, but wasn't it convention to not use negative globals? Have you checked your configuration? Per aforementioned, proposing to change $wgCantFly to $wgCanFly with a default of true.
Comment 40 Darkoneko 2010-04-17 22:32:20 UTC
Cannot replicate bug.

Please try with another volcano
Comment 41 Conrad Irwin 2010-04-17 22:33:09 UTC
from __future__ import antigravity...
Comment 42 Platonides 2010-04-17 22:37:34 UTC
You are approaching this bug from the wrong perspective.
The right fix is to move the office to Europe, where volcanos will protect it.
Comment 43 Ariel T. Glenn 2010-04-17 22:49:00 UTC
We don't need any more single point of failures. Deploying a second office should be part of our 5-year strategic plan.
Comment 44 Ævar Arnfjörð Bjarmason 2010-04-17 23:13:50 UTC
The volcano can't be stopped now but I can redirect the plume to North America instead. Would this be an acceptable solution?
Comment 45 Chad H. 2010-04-17 23:26:17 UTC
(In reply to comment #44)
> The volcano can't be stopped now but I can redirect the plume to North America
> instead. Would this be an acceptable solution?

I don't think that would be an acceptable fix, since it will only resolve the issue for some users and not all of them.

I can still clearly replicate this (and others can too, it's not /my/ setup that's the problem), so REOPENING, let's not close this until we can find an acceptable solution for all. I would suggest deprecating $wgExplodingVolcanoes as it seems to block $wgCantFly from functioning properly.
Comment 46 Ariel T. Glenn 2010-04-17 23:41:01 UTC
What was the point of the $wgExplodingVolcanoes global anyways? if it serves no useful purpose let's just revert.
Comment 47 p858snake 2010-04-18 00:02:02 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Wrong venue. Use [[WP:ANI]], [[WP:RFC/U]] or even [[WP:RFAR]] to impose
> > sanctions against the volcano.
> 
> I disagree, this is clearly outside of the English Wikipedia's scope.
> REOPENING.
Perhaps some global blocks then and some subtle hints about discussing with the board to close the project?
Comment 48 Brion Vibber 2010-04-18 00:07:21 UTC
Reassigning to Cary; as volcano coordinator this falls under his jurisdiction.
Comment 49 Simon Walker 2010-04-18 00:11:30 UTC
(In reply to comment #21)
> Suitable workaround is: apt-get install boats
> 
> Will take longer then by plane, but is only workable solution while
> $wgExplodingVolcanoes = true.

Why don't we just set $wgExplodingVolcanoes=false in GlobalSettings.php?
Or, alternatively, $wgAllowTeleport=true, though I think that's still got a small bug. I seem to recall tests on an fresh egg produced a perfect omelette. Maybe it went via Eyjafjallajökull because $wgExplodingVolcanoes=true.
Comment 50 Delphine Ménard 2010-04-18 06:57:58 UTC
Really need to cbange the bug title. I can replicate for:
1-board members of Chapters, European and worldwide
2-board members of Foundation
3-chapcom members
Note: for 1 and 2, however, those where $wgDidntFlyBeforeFriday = true seem to remain unaffected

I also suggest that anyone with $wgVisaExpiresSoon = true get priority attention.
Comment 51 Ryan Schmidt 2010-04-18 07:09:01 UTC
(In reply to comment #39)
> I don't mean to be nitpicking here, but wasn't it convention to not use
> negative globals? Have you checked your configuration? Per aforementioned,
> proposing to change $wgCantFly to $wgCanFly with a default of true.

Isn't a convention the cause of this whole mess? I mean this wouldn't be an issue if the thing in Berlin never happened (wgExplodingVolcanoes would still be true, but that's an upstream issue)

(In reply to comment #50)
> Note: for 1 and 2, however, those where $wgDidntFlyBeforeFriday = true seem to
> remain unaffected
> 
> I also suggest that anyone with $wgVisaExpiresSoon = true get priority
> attention.

Sorry to nitpick, but I believe these are members of the User object and not global variables, so User::mDidntFlyBeforeFriday and User::mVisaExpiresSoon

----

As for a relevant suggestion, I'm suggesting that a bugzilla admin lock this bug because it is for the most part pointless.
Comment 52 p858snake 2010-04-18 07:17:54 UTC
(In reply to comment #51)
> As for a relevant suggestion, I'm suggesting that a bugzilla admin lock this
> bug because it is for the most part pointless.
That is the whole point of the bug.....
Comment 53 JeLuF 2010-04-18 07:33:13 UTC
Please provide a link to a discussion page showing community consensus to set $wgExplodingVolcanoes to false. The discussion has to be approved by a steward as showing consensus and the Board of Trustees has to confirm the steward's decision on its next board meeting.

Please reopen this bug ticket once the necessary procesdures have been completed.
Comment 54 Chad H. 2010-04-18 07:38:28 UTC
(In reply to comment #51) 
> As for a relevant suggestion, I'm suggesting that a bugzilla admin lock this
> bug because it is for the most part pointless.

This Bugzilla admin says nowai, but I might be biased. You're of course free to contest this with with the "Stranded In Berliin Committee" (aka StranCom).
Comment 55 Tim Starling 2010-04-18 07:56:52 UTC
(In reply to comment #51)
> As for a relevant suggestion, I'm suggesting that a bugzilla admin lock this
> bug because it is for the most part pointless.

I think most bugzilla admins would agree that this is an important issue which needs a fix and an immediate backport to REL1_16. I do like Svip's solution (attachment #7301 [details]) but I don't have an appropriate test installation set up with time loop installed. Can anyone confirm that it actually works?
Comment 56 Jure Kajzer 2010-04-18 08:01:33 UTC
Has avar got root on the Island system??

... he could just hwclock it back to 15th and we could set $wgCatastrophesEnabled=false;
Comment 57 Guillaume Paumier 2010-04-18 08:29:32 UTC
(In reply to comment #43)
> We don't need any more single point of failures. Deploying a second office
> should be part of our 5-year strategic plan.

Hear! Hear! I unbiasedly suggest France.

(In reply to comment #0)
> Currently, due to Ævar setting off Eyjafjallajökull, most of the people
> attending the 2010 Wikimedia conference in Berlin are stranded.
> Need a patch, asap.

A temporary workaround is to use a connected series of vehicles for rail
transport that move along a track to transport freight or passengers from one
place to another, also called "train". Worked for me to get to my nächste
destination. If insufficient, it may be coupled to other modes of
transportation such as bicycling, swimming and ostrich-riding.
Comment 58 Tim Starling 2010-04-18 08:57:27 UTC
(In reply to comment #57)
> A temporary workaround is to use a connected series of vehicles for rail
> transport that move along a track to transport freight or passengers from one
> place to another, also called "train".

Some people with high-RTT locations may experience unacceptable load times if we use this method, see e.g. http://seat61.com/Australia-overland.htm
Comment 59 Max Semenik 2010-04-18 10:11:45 UTC
Requesting an urgent switch to git so that we could use bisect to find the revision where the bug was introduced. If someone wants to discuss what to do with the offending developer, they can open a separate bug.
Comment 60 Simon Walker 2010-04-18 10:31:00 UTC
(In reply to comment #59)
> Requesting an urgent switch to git so that we could use bisect to find the
> revision where the bug was introduced. If someone wants to discuss what to do
> with the offending developer, they can open a separate bug.

does svn blame not to this?
Comment 61 Max Semenik 2010-04-18 10:38:26 UTC
(In reply to comment #60)

> does svn blame not to this?

No, as we don't know exact line with borkage. Besides, it's fun!
Comment 62 Siebrand Mazeland 2010-04-18 10:41:19 UTC
(In reply to comment #59)
> Requesting an urgent switch to git so that we could use bisect to find the
> revision where the bug was introduced. If someone wants to discuss what to do
> with the offending developer, they can open a separate bug.

No need to use git. We just svn blame and find core did it.
Comment 63 Chad H. 2010-04-18 11:11:47 UTC
Maybe we're approaching this in entirely the wrong way...the meteorologists are saying that due to the unseasonably sunny skies, the ash cloud isn't moving away. They are saying that if rained, more of the ash would be cleansed from the skies. Perhaps we should be trying to go that route?
Comment 64 Max Semenik 2010-04-18 11:18:20 UTC
(In reply to comment #63)
> Maybe we're approaching this in entirely the wrong way...the meteorologists are
> saying that due to the unseasonably sunny skies, the ash cloud isn't moving
> away. They are saying that if rained, more of the ash would be cleansed from
> the skies. Perhaps we should be trying to go that route?

Renamed the bug accordingly.
Comment 65 Thor Malmjursson 2010-04-18 12:02:12 UTC
Someone kindly suggested above that the convention is to move away from Negative globals; to this extent, I am recommending the deprecation of $wgCantFly, which currentlyis set to true (normally defaults to false), and calling for the inclusion of the $wgCanFly global, which would normally default to true.

I know in the present situation it is still running as false, but surely if we try and improve the positive vibes from using positive globals, we might be able to make this easier to rectify.
Comment 66 Milos Rancic 2010-04-18 14:17:21 UTC
My grandfather is a shaman and I know a little bit of his business... Actually, I am a zduhac [1] and I am dealing with clouds. (I have to add into my portfolio that I moved clouds out of Belgrade.)

However, I am not in Berlin and I can't help. Because of that, I've started course at Meta [2] for those who are willing to work on moving clouds out of Belgrade.

[1] - http://en.wikipedia.org/wiki/Zduhac
[2] - http://meta.wikimedia.org/wiki/How_to_become_a_zduhac
Comment 67 Chad H. 2010-04-18 15:17:39 UTC
(In reply to comment #32)
> Also, this doesn't seem to be a usability issue, but something on the back-end.
> Changing the painting of the airplane won't fix the problem.

I'm not so sure about that, it could be an acceptable workaround for now. If we paint the plane like an ashcloud, Eurocontrol might not notice you.
Comment 68 Platonides 2010-04-18 20:31:59 UTC
Maybe WM-FR can take there an appropiate man [1]? He already proved to be able to fix the issue [2].

Additionally, that would allow us to take him a photo to place in his biography.

1-http://fr.wikipedia.org/wiki/Assurancetourix
2-http://fr.wikipedia.org/wiki/Ast%C3%A9rix_chez_Rah%C3%A0zade
Comment 69 p858snake 2010-04-19 01:46:39 UTC
(In reply to comment #66)
> My grandfather is a shaman and I know a little bit of his business... Actually,
> I am a zduhac [1] and I am dealing with clouds. (I have to add into my
> portfolio that I moved clouds out of Belgrade.)
> 
> However, I am not in Berlin and I can't help. Because of that, I've started
> course at Meta [2] for those who are willing to work on moving clouds out of
> Belgrade.
> 
> [1] - http://en.wikipedia.org/wiki/Zduhac
> [2] - http://meta.wikimedia.org/wiki/How_to_become_a_zduhac

Could be a useful wikiversity course >.>
Comment 70 Austin Hair 2010-04-19 12:07:46 UTC
> (In reply to comment #57)
> > A temporary workaround is to use a connected series of vehicles for rail
> > transport that move along a track to transport freight or passengers from one
> > place to another, also called "train".

Confirmed that this is a successful workaround.
Comment 71 Sam Reed (reedy) 2010-04-19 16:54:07 UTC
Hekla has just decided to cause more problems
Comment 72 Chad H. 2010-04-19 17:19:42 UTC
Widening the scope of the bug. Iceland is no longer useful to the rest of humanity. Perhaps we should investigate ways to remove it from the planet.
Comment 73 Siebrand Mazeland 2010-04-19 17:21:37 UTC
(In reply to comment #72)
> Perhaps we should investigate ways to remove it from the planet.
No personal attacks, please. Islands have feelings, too!
Comment 74 Ævar Arnfjörð Bjarmason 2010-04-19 17:31:38 UTC
(In reply to comment #71)
> Hekla has just decided to cause more problems

Don't believe everything you read online.
Comment 75 Church of emacs 2010-04-19 17:34:17 UTC
(In reply to comment #72)
> Widening the scope of the bug. Iceland is no longer useful to the rest of
> humanity. Perhaps we should investigate ways to remove it from the planet.

This fixes the problem only partially. Volcanoes exist elsewhere, too. While I understand that Iceland's debt is also an issue, that should go to a separate bug report.
Comment 76 Ariel T. Glenn 2010-04-19 17:43:02 UTC
Let's not throw out the baby with the bath-water.  I'm afraid this is really a political issue: what we need is better enforcement of no-smoking policies in public areas in Iceland.  Just because the violator is a volcano is no excuse to look the other way at this kind of behavior.
Comment 77 Andrew Garrett 2010-04-19 17:45:10 UTC
I think I've found a more feasible resolution to this issue
Comment 78 Ariel T. Glenn 2010-04-19 17:47:29 UTC
As referenced earlier, we want to avoid creating more SPOF's.
Comment 79 Thor Malmjursson 2010-04-19 20:03:35 UTC
In regard to what I stated above, about the deprecation of $wgCantFly, it appears someone has included $wgCanFly = true and put it in the config, communication suggests that this global may become generally active from about 7 to 8am UTC+1 on 20th April.

Incidentally, I believe having a WMF branch office in .de or .be would eliminate the need for a bug of this nature to arise again, since any stranded staff could converge to a branch office and remain in contact with their work and colleagues until they could make their way back to /dev/hda6 [home] :)
Comment 80 Andrew Leung 2010-04-19 21:57:59 UTC
(In reply to comment #72)
> Widening the scope of the bug. Iceland is no longer useful to the rest of
> humanity. Perhaps we should investigate ways to remove it from the planet.

As a guy who studied climatology and global warming, I daresay that we need more volcanoes (not less) in the face of climate change. They are an effective force to cool down the earth naturally.
Comment 81 Platonides 2010-04-19 22:19:33 UTC
> As a guy who studied climatology and global warming, I daresay that we need
> more volcanoes (not less) in the face of climate change. They are an effective
> force to cool down the earth naturally.

They are also ecological by preventing planes from flying!
Comment 82 Amgine 2010-04-19 22:28:54 UTC
(In reply to comment #81)
> > As a guy who studied climatology and global warming, I daresay that we need
> > more volcanoes (not less) in the face of climate change. They are an effective
> > force to cool down the earth naturally.
> 
> They are also ecological by preventing planes from flying!

However, planes have much the same effect, so if we had *more* planes flying there'd be less need for vulcanism for cooling.

On the other hand, I understand Spain is offering to allow hubbing for airlines as of today. The general flow is get to the border of France, rent cars to avoid the train strike, get back on the train in Spain...
Comment 83 Platonides 2010-04-19 22:35:05 UTC
You couldn't come into Spain using just one train, anyway. It's broken by design so you can't invade us!
Comment 84 Roan Kattouw 2010-04-20 22:02:28 UTC
Improvised office has been set up in the hotel lounge, see http://www.flickr.com/photos/brevity/4537231779/sizes/l/ . Resolving as FIXED.
Comment 85 Philippe Beaudette 2010-04-20 22:18:17 UTC
Reopening bug. 

Since when has a change in operating environment been an acceptable bug fix?
Comment 86 Ariel T. Glenn 2010-04-20 22:19:45 UTC
It worked for the bathroom issues at Stillman :-P
Comment 87 Roan Kattouw 2010-04-20 23:30:40 UTC
(In reply to comment #85)
> Reopening bug. 
> 
> Since when has a change in operating environment been an acceptable bug fix?

Bug summary: "Estabilsh Wikimedia branch office in Germany". The hotel lobby seems to be functioning as an office with like a dozen people working there. That's only a few people less than we currently have in SF, so it would seem to qualify as a fully-fledged branch.

Feel free to REOPEN if you think luring people to Berlin and telling them stories about volcanoes to make them stay is not an acceptable way of setting up a branch office.
Comment 88 p858snake 2010-04-21 22:42:43 UTC
Perhaps a office in Australia to avoid single point of failure for these things.... thus people that commit bad code (or regessions that last for several years) can be introduced to our native fauna and flora....

Althought the thought of threating with a volcano in iceland is also intresting....
Comment 89 Darkoneko 2010-04-23 11:28:36 UTC
I'm not sure opening a 2nd office in an *island* would help much in case of plan problems
Comment 90 Darkoneko 2010-04-23 11:29:03 UTC
I'm not sure opening a 2nd office in an *island* would help much in case of plane problems

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links