Last modified: 2014-04-07 14:07:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23052 - Edit window should not scroll when inserting text in WikiEditor's iframe mode (using toolbar, special characters or dialogs)
Edit window should not scroll when inserting text in WikiEditor's iframe mode...
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 23060 23446 (view as bug list)
Depends on:
Blocks: 24493 36111
  Show dependency treegraph
 
Reported: 2010-04-05 10:33 UTC by Calcey QA
Modified: 2014-04-07 14:07 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-04-05_NumberList.pdf (438.31 KB, application/pdf)
2010-04-05 10:33 UTC, Calcey QA
Details

Description Calcey QA 2010-04-05 10:33:07 UTC
Created attachment 7265 [details]
Wiki_2010-04-05_NumberList.pdf

Reporting against Babaco Release : r64562
Tested link :http://prototype.wikimedia.org/deployment-en/Main_Page

Steps to Reproduce ::

1) Select on a position few scrolls down and Click on Numbered list item
2) Screen position changes. When you scroll down the insert position is there. Cursor position is not changing.


Expected Outcome::

Page scroll should not be happen

Test Environment::
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Comment 1 Calcey QA 2010-04-05 10:36:36 UTC
(In reply to comment #0)
> Created an attachment (id=7265) [details]
> Wiki_2010-04-05_NumberList.pdf
> 
> Reporting against Babaco Release : r64562
> Tested link :http://prototype.wikimedia.org/deployment-en/Main_Page
> 
> Steps to Reproduce ::
> 
> 1) Select on a position few scrolls down and Click on Numbered list item
> 2) Screen position changes. When you scroll down the insert position is there.
> Cursor position is not changing.
> 
> 
> Expected Outcome::
> 
> Page scroll should not be happen
> 
> Test Environment::
> Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100202
> Firefox/3.5.8

Same thing happen when adding a indentation in the same way
Comment 2 Calcey QA 2010-04-07 11:33:37 UTC
Similar happen in Mac Safari 3.2

I highlighted and marked a text as nowiki which is few scrolls down in the editor and the editor jumps up
Comment 3 Roan Kattouw 2010-05-08 21:06:12 UTC
Broadening bug: this seems to happen for all insertions in all browsers.
Comment 4 Roan Kattouw 2010-05-08 21:06:26 UTC
*** Bug 23060 has been marked as a duplicate of this bug. ***
Comment 5 Roan Kattouw 2010-05-08 21:06:40 UTC
*** Bug 23446 has been marked as a duplicate of this bug. ***
Comment 6 Roan Kattouw 2010-05-11 17:25:19 UTC
Fixed in r66026.
Comment 7 nkomura@wikimedia.org 2010-05-12 05:08:02 UTC
Working great in FF3.5 on Ubuntu 9.10. :-)
Comment 8 Calcey QA 2010-05-12 05:59:16 UTC
The numbered list appear at the top of the page in IE8 and IE7 on Vista.


Steps to reproduce::
1) Access the URL http://prototype.wikimedia.org/en.wikipedia.org/Main_Page
2) Click on Random Page link
3) Click on Edit tab
4) Scroll down a bit in Edit window 
5) Place cursor somewhere in the middle of the page 
6) Click on 'Numbered List' icon from the Advanced toolbar 

The '# Numbered list item' text is inserted to the top of the page irrespective of the cursor position.

This issue is reproducible when other icons are clicked too.



Reopening the bug.

Note:
This issue is verified as fixed in Opera 10, Safari 4/3 and Firefox 3
Comment 9 Calcey QA 2010-05-12 06:18:16 UTC
Please note that this issue is not fixed in Safari 3.2.
Comment 10 Calcey QA 2010-05-12 09:40:38 UTC
This issue is fixed when NTOC feature is turned off.
Comment 11 Roan Kattouw 2010-05-12 14:53:34 UTC
(In reply to comment #10)
> This issue is fixed when NTOC feature is turned off.

Adjusting summary accordingly.
Comment 12 Helder 2010-10-20 12:56:17 UTC
This is still happening at en.wikipedia, for every button.
Comment 13 Mark A. Hershberger 2011-04-14 18:55:26 UTC
Just saw this on enwiki for numbered list in FF4 on Windows.  Every other item was blank so you ended up with:

# 
# Numbered list item
# 
# Numbered list item
# 
# Numbered list item
# 
# Numbered list item
Comment 14 Roan Kattouw 2011-04-18 19:09:08 UTC
(In reply to comment #13)
> Just saw this on enwiki for numbered list in FF4 on Windows.  Every other item
> was blank so you ended up with:
> 
That's a /completely/ different bug. Also, this bug pertains to iframe mode.

It is a valid bug though.
Comment 15 Krinkle 2011-05-02 21:14:37 UTC
BugTriage:

Moving to new WikiEditor component, clarifying summary, lowering priority (as the iframe mode is disabled by default and not ready for production in general).
Comment 16 Bugmeister Bot 2011-08-19 19:12:49 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 17 Andre Klapper 2014-04-07 14:07:28 UTC
The unmaintained beta iframe mode was removed from WikiEditor recently in WikiEditor: https://gerrit.wikimedia.org/r/#/c/123649/

Hence closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links