Last modified: 2011-01-25 00:06:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21622 - loading a wikipedia article crashes my browser
loading a wikipedia article crashes my browser
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 21752 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-24 02:37 UTC by Rich Schroeppel
Modified: 2011-01-25 00:06 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rich Schroeppel 2009-11-24 02:37:16 UTC
Apparently, attempting to load any Wikipedia article crashes my browser.
I can view the front page at http://www.wikipedia.org/, but entering
either "calcium" or "Big_O_Notation" in the search bar and middle-clicking
creates a new browser tab, spins for a few seconds, then kills the browser.
[Incidentally, there's no option on the front page to submit a bug report,
and clicking meta-wiki also kills the browser.]
The browser dies with Exit 11.
Another way to the same kill is to click on a link pointing to an article
from another web page.  For example, the QuantumAlgorithmZoo page has a
pointer to a wikipedia article explaining Big_O_Notation; clicking on that
link kills the browser.
This is a new problem, things worked fine before.  I think I used Wikipedia
within the last week, but it might be as much as three weeks ago.
I'm running a very old browser, Mozilla 1.2.1,
   Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
and I don't use Flash.  Most cookie are disabled.
I assume you've recently revised the stuff surrounding each article to
use some new exotic web feature which poisons my old browser.
Any advice you could provide would be appreciated-- perhaps a text-only
entry point?

Rich Schroeppel   rcs@xmission.com

PS: I hope the buttom labeled Commit means "Submit Bug Report".
Comment 1 Roan Kattouw 2009-11-24 12:09:03 UTC
(In reply to comment #0)
> I assume you've recently revised the stuff surrounding each article to
> use some new exotic web feature which poisons my old browser.
> Any advice you could provide would be appreciated-- perhaps a text-only
> entry point?
> 
We did no such thing. Your browser should not allow unexpected input to crash it; if it does, that's a bug in your browser. Recommend INVALID on those grounds.
Comment 2 Splarka 2009-11-25 21:23:48 UTC
(In reply to comment #0)
> I assume you've recently revised the stuff surrounding each article to
> use some new exotic web feature which poisons my old browser.

It also crashes my older mozilla but only with javascript enabled.

A small sacrifice for "Usability" (whatever that means... apparently nothing to do with "use" or "ability").
Comment 3 Roan Kattouw 2009-11-25 21:26:19 UTC
(In reply to comment #2)
> It also crashes my older mozilla but only with javascript enabled.
> 
> A small sacrifice for "Usability" (whatever that means... apparently nothing to
> do with "use" or "ability").
> 
Can you confirm that it's indeed the usability JS that causes this? Is there something we can do about it?
Comment 4 Max Semenik 2009-12-03 19:38:51 UTC
*** Bug 21752 has been marked as a duplicate of this bug. ***
Comment 5 Max Semenik 2009-12-03 19:40:05 UTC
Seems to be cross-platform, from bug 21752:
Mac OS 8.6, "Mozilla/5.0 (Macintosh; U; PPC; fr-FR; rv:1.3.1) Gecko/20030723 wamcom.org".
Comment 6 John Doe 2009-12-24 21:36:10 UTC
I can confirm this bug

Win XP Pro SP2
Mozilla 1.7.2.2004080302
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803

As mentioned by Rich Schroeppel, the home page loads OK, but if I navigate to "English" or any other article, it crashes.  Also, as mentioned by Splarka, it does not crash if javascript is disabled.

I think it's caused by the current banner "Please read: A personal appeal from Wikipedia founder Jimmy Wales."  The banner is absent from the home page and does not appear when javascript is turned off.  The banner is javascript:goToDonationPage(), redirecting to this URL:

http://wikimediafoundation.org/wiki/Appeal2/en?utm_source=2009_Jimmy_Appeal9&utm_medium=sitenotice&utm_campaign=fundraiser2009&target=Appeal2

Mozilla.exe
Error signature
AppName: mozilla.exe
AppVer:1.7.20040.14766
ModName: js3250.dll
ModVer: 4.0.0.0
Offset: 000181c5

js3250.dll, Netscape 32-bit JavaScript Module
located in C:\Program Files\Common Files\mozilla.org\GRE\1.7.2_2004080302

I hope this info helps.  Maybe the bug will pass once the banner is gone, but in the meantime, it's inconvenient to turn off javascript when it's necessary for so many other sites.  If I come across links to Wiki, I have to copy them into Internet Explorer.
Comment 7 Chad H. 2010-03-01 18:20:33 UTC
Now that the fundraising banners are gone, does this still happen?
Comment 8 Rich Schroeppel 2010-03-01 21:51:09 UTC
I found the original suggestion to turn off scripting was helpful.
It allowed me to use the site, albeit with somewhat reduced functionality.
(This also fixed some problems I was having with Google and Google News!?)
I needed scripting for some other sites, so I was turning it on & off
frequently.  Sometime, maybe in January, I forgot to turn off scripting,
and discovered that my Wikipedia problem had gone away, and things now worked
even with scripting ON.  Similarly, Google and Google News again worked with
scripting turned ON.
I can only guess that the banners were the problem.
I suspect in the case of Google that their search-completion feature was
the problem.  I can't imagine how that relates to the WP funding banner.
Comment 9 John Doe 2010-04-02 13:20:44 UTC
I don't think it was solely the fundraising banners.  Shortly after they were gone, Mozilla 1.7.2 still crashed with javascript enabled.  Eventually the problem went away, so I figured the source of the problem had been found, but there were no updates to this thread at the time.

Long before the Wiki problem, Google maps would crash it too.  Started right after some Win XP updates, and still persists.
Comment 10 DieBuche 2010-12-05 14:07:23 UTC
Both had 0.001% market share in oktober 2010 and judging from above reply the problem was accidentaly fixed (?)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links