Last modified: 2014-03-09 18:05:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21102 - Don't propose to create a page under a title with prefix:, intitle:, incategory: or other search operators
Don't propose to create a page under a title with prefix:, intitle:, incatego...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
unspecified
All All
: Low enhancement with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Wikipedi...
:
: 21137 21467 29989 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 00:12 UTC by Cenarium
Modified: 2014-03-09 18:05 UTC (History)
12 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Cenarium 2009-10-12 00:12:32 UTC
When the search uses parameters prefix:, intitle: or +incategory:, it should not propose to create the page. See link, new users have been confused by this when searching archives and created pages like <something> prefix:Talk:Main Page . It seems unlikely that pages containing any of those strings need to be created.
Comment 1 Chad H. 2009-10-13 13:22:44 UTC
These are legitimate page title names, no need for the software to block them.

If a local wiki doesn't want them, an AbuseFilter or entry to the page title blacklist are more appropriate. Marking WONTFIX.
Comment 2 Brion Vibber 2009-10-14 19:05:49 UTC
Where they're syntactical elements of a search query they really should be excluded from the search suggestion.
Comment 3 Brion Vibber 2009-10-14 19:06:03 UTC
*** Bug 21137 has been marked as a duplicate of this bug. ***
Comment 4 Robert Stojnic 2009-11-23 13:48:22 UTC
*** Bug 21467 has been marked as a duplicate of this bug. ***
Comment 5 spage 2013-06-17 19:52:03 UTC
This also happens with the ~ and - prefixes, and the * suffix.
Comment 6 Nemo 2013-12-05 16:46:56 UTC
MediaWiki:Searchmenu-new is also a bit ugly: '''Create the page "[[:$1]]" on this wiki!''' I understand the bold, but the exclamation mark? While at it, if this bug is fixed the message can be made a bit more encouraging, like «'''You can create the page "[[:$1]]" on this wiki.'''» (such a wording would currently make the effects of this bug worse); the bug 27311 could make the link more helpful and always valid whatever the permissions/processes on the wiki.
Comment 7 PartTimeGnome 2013-12-12 22:34:55 UTC
As mentioned on bug 29989, this is also the case with double quotes used in search phrases.
Comment 8 Helder 2013-12-13 00:03:51 UTC
*** Bug 29989 has been marked as a duplicate of this bug. ***
Comment 9 Chad H. 2014-02-17 05:07:36 UTC
We actually did this with Cirrus. If other backends support fancy syntax and want to do the same, they can too by returning true in SearchResultSet::searchContainedSyntax() implementations.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links