Last modified: 2012-08-04 20:49:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21030 - Setting a new schema for postgres doesn't work
Setting a new schema for postgres doesn't work
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.15.x
All All
: Normal critical (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 21207 (view as bug list)
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2009-10-07 07:43 UTC by Joshua Hutchins
Modified: 2012-08-04 20:49 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Joshua Hutchins 2009-10-07 07:43:56 UTC
Setting a new schema (other than "mediawiki") doesn't work when using Postgres.  Although I've entered a different schema in the box, the install page still shows that it's looking at the mediawiki schema (and "mediawiki" is entered in LocalSettings.php)

There are two form fields on the installation page named "DBmwschema"- one for Postgres, one for DB2.  The one for DB2, set to its default value of "mediawiki", comes later and effectively overwrites the one in the Postgres database options box.
Comment 1 OverlordQ 2009-10-07 08:48:47 UTC
(hopefully) Fixed in r57454
Comment 2 Joshua Hutchins 2009-10-07 16:31:08 UTC
Thanks a ton!
Comment 3 Alexandre Emsenhuber [IAlex] 2009-10-21 12:48:45 UTC
*** Bug 21207 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links