Last modified: 2011-07-24 11:33:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20934 - LiquidThreads has no support for RTL
LiquidThreads has no support for RTL
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
LiquidThreads (Other open bugs)
unspecified
All All
: High major with 5 votes (vote)
: ---
Assigned To: asharma
: i18n
: 20909 (view as bug list)
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2009-10-01 19:48 UTC by Andrew Garrett
Modified: 2011-07-24 11:33 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Andrew Garrett 2009-10-01 19:48:00 UTC
No support for RTL environments in LiquidThreads.
Comment 1 Andrew Garrett 2009-10-13 16:07:40 UTC
*** Bug 20909 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Garrett 2009-10-13 16:09:20 UTC
These bugs block full-scale roll-out of LiquidThreads (batch-change).
Comment 3 Brandon Harris 2010-09-10 01:42:22 UTC
I need to take this for now so that I can plan designs for it.
Comment 4 Amir E. Aharoni 2010-10-30 19:31:28 UTC
Is there anything i can do to help? I'm not much of a MediaWiki developer, but maybe i can help testing. The demand for this to work in Hebrew is growing.
Comment 5 Derk-Jan Hartman 2011-01-09 17:15:11 UTC
Largely fixed by r79905. Needs some cleanup with regard to direction of reply image perhaps and some other smaller details.
Comment 6 Derk-Jan Hartman 2011-01-11 20:39:06 UTC
r80030 fixes the thread collapse arrow
Comment 7 Amir E. Aharoni 2011-01-13 09:42:32 UTC
Thanks a lot.

Is it possible to test these fixes in some full-fledged RTL wiki?
Comment 8 Derk-Jan Hartman 2011-01-13 11:12:07 UTC
In theory you can test it here: http://prototype.wikimedia.org/ar.wikipedia.org/نقاش:الصفحة_الرئيسية

But the prototype seems out of date and broken atm.
Comment 9 Roan Kattouw 2011-01-13 14:29:11 UTC
(In reply to comment #8)
> In theory you can test it here:
> http://prototype.wikimedia.org/ar.wikipedia.org/نقاش:الصفحة_الرئيسية
> 
> But the prototype seems out of date and broken atm.
The prototype runs the 1.17 branch, and your fixes haven't been merged into it yet.
Comment 10 Siebrand Mazeland 2011-03-20 19:56:18 UTC
Setting to high/major, as RTL support in MediaWiki is considered very important, and a priority extension not supporting it, is bad.
Comment 11 Mark A. Hershberger 2011-05-03 20:04:38 UTC
Giving to Alolita so she can find an appropriate developer to work on this.
Comment 12 Robin Pepermans (SPQRobin) 2011-07-06 03:18:08 UTC
Fixed most or all issues in trunk (see commits: http://www.mediawiki.org/w/index.php?path=%2Ftrunk%2Fextensions%2FLiquidThreads&title=Special%3ACode%2FMediaWiki/author/robin ).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links