Last modified: 2014-03-11 12:18:50 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20852 - Provide system/option to login without doing a global login
Provide system/option to login without doing a global login
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
CentralAuth (Other open bugs)
unspecified
All All
: Normal enhancement with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 25733
  Show dependency treegraph
 
Reported: 2009-09-28 14:22 UTC by Platonides
Modified: 2014-03-11 12:18 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Platonides 2009-09-28 14:22:51 UTC
Provide a checkbox "Log in globally" on Special:Userlogin that can be unchecked to not start session on the other sites using SUL.
Comment 1 Victor Vasiliev 2009-09-28 14:24:28 UTC
How is it supposed to predetermine whether account is SUL or not?
Comment 2 Platonides 2009-09-28 14:27:18 UTC
It would probably do nothing if the account is not SULed.
The request is to provide a way for SUL accounts not to be globally logged.
Comment 3 Platonides 2010-10-19 21:17:18 UTC
*** Bug 24471 has been marked as a duplicate of this bug. ***
Comment 4 Platonides 2010-10-19 21:19:31 UTC
Fixed in r75041.
Comment 5 Brion Vibber 2011-02-17 00:42:38 UTC
Reopening with a recommendation to revert -- this is a thing that's very rarely of general use, but it clogs up UI for everyone.
Comment 6 Aryeh Gregor (not reading bugmail, please e-mail directly) 2011-02-17 00:49:58 UTC
Agree with revert suggestion.
Comment 7 Thor Malmjursson 2011-02-17 00:51:04 UTC
Seconded, thirded and fourthed. +1 to brion for the suggestion.
Comment 8 p858snake 2011-02-17 00:51:21 UTC
or at least make sure this is checked by default for users, it does appear to
be for me but not others.

It could probably do with a better local message to indicate logging in to the
wmf projects globally.
Comment 9 MZMcBride 2011-02-17 05:03:59 UTC
Brion started a mailing list discussion about this here: http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/52265
Comment 10 Platonides 2011-02-17 23:01:22 UTC
> or at least make sure this is checked by default for users, it does appear to
> be for me but not others.

I made sure of that. That's the true parameter of r75041.
It is correctly shown in the html:
<input name="wpCentralLogin" type="checkbox" value="1" checked="checked" id="wpCentralLogin" tabindex="4" />

What kind of browser are they using??


> It could probably do with a better local message to indicate logging in to the
> wmf projects globally.

Feel free to fix it. Can WikimediaMessages extension override it?
Comment 11 Bawolff (Brian Wolff) 2011-02-17 23:05:51 UTC
What was the usecase/reason for this?
Comment 12 Nemo 2011-04-25 11:47:22 UTC
Any progress on reverting?

Bug 28369 suggests yet another preference for CentralAuth.
Comment 13 Nemo 2011-06-15 06:37:16 UTC
Ditto. Yesterday we (WMI) had a Wikipedia editing course with some NGO people we're working with and they found this extremely confusing (not very scientific argument, but still).
I think this should be reverted as soon as possible, even before another solution is implemented; it's easy for us to get accustomed to a thing like this, which however is now actively hindering normal users from editing.
Comment 14 Bugmeister Bot 2011-08-19 19:13:00 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 15 MZMcBride 2011-12-20 19:41:06 UTC
r75041 was reverted by Brion in r106839 and merged into the 1.18wmf1 branch by Reedy in r106840.

One reason a user might want to log in to only one site is account security. An unprivileged account on one site might be privileged elsewhere. This use-case probably doesn't justify the UI clutter, though.
Comment 16 Bawolff (Brian Wolff) 2011-12-20 21:57:29 UTC
Anyone who actually wants this is probably a super-duper power user. If people want this, how about we have it as a hidden option. If people go to something like http://en.wikipedia.org/wiki/special:userlogin people login globally like normally, no check box presented, but if people go to http://en.wikipedia.org/wiki/special:userlogin?noglobal then it doesn't log you in globally (or presents you with the checkbox) So we don't have any ui clutter, but people who actually want it can use it (but then it'd be very hard to discover)
Comment 17 p858snake 2011-12-28 07:54:26 UTC
Comments from someone that used this feature (before the revert): http://www.mediawiki.org/wiki/Thread:Project:Support_desk/Unified_Login_changed_in_past_week:_no_longer_possible_to_login_to_single_account%3F
Comment 18 Nemo 2013-03-06 16:12:17 UTC
More than a year since last comment, there's still no provided rationale justifying the need for this -> closing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links