Last modified: 2009-09-29 14:13:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20797 - "Move subpages" option causes database query syntax error
"Move subpages" option causes database query syntax error
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.16.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 20876 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-24 19:22 UTC by MZMcBride
Modified: 2009-09-29 14:13 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MZMcBride 2009-09-24 19:22:21 UTC
When moving pages with the "move subpages" option checked on en.wiki, I consistently get a database syntax query error, for example:

A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:
(SQL query hidden)
from within function "MovePageForm::moveToNewTitle". Database returned error "1062: Duplicate entry '4-Database_reports/Recently_created_biographies_of_living_people' for key 2 (10.0.6.26)".

It moves the root page, but doesn't move any of the subpages.
Comment 1 Bryan Tong Minh 2009-09-24 19:29:24 UTC
For which page do you get the error? For all pages or only specific pages?
Comment 2 MZMcBride 2009-09-24 19:31:29 UTC
This happens for all pages. And it happens on test.wikipedia as well as en.wiki. Only happens when the "move subpages" box is checked. Seems to be consistent if the checkbox is checked, though.
Comment 3 Alexandre Emsenhuber [IAlex] 2009-09-25 15:31:03 UTC
Should be fixed in r56920.
Comment 4 Chad H. 2009-09-29 14:13:30 UTC
*** Bug 20876 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links