Last modified: 2009-10-24 18:54:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20668 - Enhanced Editor Bar hanging on IE 8
Enhanced Editor Bar hanging on IE 8
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major with 1 vote (vote)
: ---
Assigned To: Roan Kattouw
: code-update-regression
: 20670 20680 20704 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-17 04:20 UTC by Robert Rohde
Modified: 2009-10-24 18:54 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Robert Rohde 2009-09-17 04:20:09 UTC
Since the recent software update I find that trying to edit any page with the "Enable enhanced editing toolbar" preference turned on causes IE 8.0 to hang for about 20 seconds and then create a popup message saying: "Out of memory at line: 76" (presumably a javascript error, though the message box doesn't mention that).

This behavior is specific to IE and does not occur with Firefox.  However it does occur with both the Monobook and Vector skins.  Also, I verified that the problem occurs on several different language Wikipedias.

The problem persists even after clearing my cache.
Comment 1 Roan Kattouw 2009-09-17 12:34:16 UTC
*** Bug 20670 has been marked as a duplicate of this bug. ***
Comment 2 Roan Kattouw 2009-09-17 12:47:08 UTC
*** Bug 20680 has been marked as a duplicate of this bug. ***
Comment 3 Brion Vibber 2009-09-17 21:18:16 UTC
Assigning to Roan as Trevor's currently out on paternity leave.
Comment 4 HenkvD 2009-09-17 21:23:06 UTC
Same problem for IE7. I could not edit for the whole day at all, until I read it in this bug report. Either make it widely known, or solve it  
Comment 5 Brion Vibber 2009-09-17 21:39:40 UTC
I've disabled the new edit toolbar pending fixes. :(
Comment 6 Brion Vibber 2009-09-17 21:50:58 UTC
*** Bug 20704 has been marked as a duplicate of this bug. ***
Comment 7 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-09-17 22:13:28 UTC
I'm guessing this is because of the overall extreme slowness of the edit toolbar construction . . . IIRC, wasn't it hanging for a second or two even on Firefox?  IE has a much slower JS engine.  I think I discussed this with either Roan or Trevor at some point.
Comment 8 Robert Rohde 2009-09-17 22:30:02 UTC
(In reply to comment #7)
> I'm guessing this is because of the overall extreme slowness of the edit
> toolbar construction . . . IIRC, wasn't it hanging for a second or two even on
> Firefox?  IE has a much slower JS engine.  I think I discussed this with either
> Roan or Trevor at some point.

I don't know about that.  It felt more like an infinite loop slowly consuming more and more resources until it ate everything the system would allow it to have and it died.  Duplicate bug 20680 mentions page swapping and over a gigabyte of memory use.
Comment 9 RockMFR 2009-09-18 03:13:04 UTC
for ( msg in configuration.buttons ) {
  configuration.buttons[gM( msg )] = configuration.buttons[msg];
  delete configuration.buttons[msg];
}

Find the bug! :)
Comment 10 Roan Kattouw 2009-09-18 09:05:36 UTC
(In reply to comment #9)
> for ( msg in configuration.buttons ) {
>   configuration.buttons[gM( msg )] = configuration.buttons[msg];
>   delete configuration.buttons[msg];
> }
> 
> Find the bug! :)
> 

Hehehe, interesting.

This code adds new properties to the object being iterated on. Firefox doesn't loop over these newly added properties, IE8 does, causing it to grow the object indefinitely.

Fix is underway.
Comment 11 Roan Kattouw 2009-09-18 09:13:27 UTC
(In reply to comment #10)
> Fix is underway.
> 
r56588 should do it.
Comment 12 Calcey QA 2009-09-18 09:14:53 UTC
This bug was noticed in Avant 11.7 web browser too.

Environment details ::

Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0;Trident/4.0; GTB6; Avant Browser; SLCC1; .NET CLR 2.0.50727; Media Center PC5.0; .NET CLR 3.5.21022; .NET CLR 1.1.4322; InfoPath.2; .NET CLR 3.5.30729;.NET CLR 3.0.30618) 
Javascript: Enabled 
Cookies Enabled: Enabled  
Java Enabled: Enabled  
CPU class/type: CPU Class x86  
Screen Width x Height: 1280 x 800  
Screen Color Depth: 32  
Window Width: 585 (45.7% of 1280)  
Window Height: 353 (44.1% of 800)  
Comment 13 Roan Kattouw 2009-09-18 11:08:38 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Fix is underway.
> > 
> r56588 should do it.
> 

This fix has been deployed and the toolbar reenabled. Please test with IE8 and close this bug if the issue is fixed.
Comment 14 Roan Kattouw 2009-09-18 11:10:28 UTC
(In reply to comment #7)
> I'm guessing this is because of the overall extreme slowness of the edit
> toolbar construction . . . IIRC, wasn't it hanging for a second or two even on
> Firefox?  IE has a much slower JS engine.  I think I discussed this with either
> Roan or Trevor at some point.
> 

I've made some performance improvements some time after that conversation, which made it run 5.6 times faster. It's been a while, though, so I'm gonna take a look at it again to verify that recent development hasn't caused performance to degrade too much.
Comment 15 Roan Kattouw 2009-09-18 11:15:07 UTC
(In reply to comment #13)
> (In reply to comment #11)
> > (In reply to comment #10)
> > > Fix is underway.
> > > 
> > r56588 should do it.
> > 
> 
> This fix has been deployed and the toolbar reenabled. Please test with IE8 and
> close this bug if the issue is fixed.
> 

I asked someone on IRC, and apparently the issue is fixed.
Comment 16 Calcey QA 2009-10-24 18:54:59 UTC
Verified. It is working. 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links