Last modified: 2012-06-27 12:28:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20360 - Unicode directionality marker causes parentheses error in edit summary
Unicode directionality marker causes parentheses error in edit summary
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
http://simple.wikipedia.org/w/index.p...
: i18n
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2009-08-23 01:12 UTC by Jon
Modified: 2012-06-27 12:28 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
diff description/summary on right has two left parens instead of a left and a right (19.87 KB, image/png)
2011-10-07 20:14 UTC, Sumana Harihareswara
Details
revision history displaying the problematic edit summary (8.48 KB, image/png)
2011-10-07 20:18 UTC, Sumana Harihareswara
Details

Description Jon 2009-08-23 01:12:13 UTC
Parenthesis facing the wrong way in this diff:

http://simple.wikipedia.org/w/index.php?title=Xenu&diff=prev&oldid=1698000
Comment 1 Niklas Laxström 2009-08-23 06:45:53 UTC
There doesn't seem to be any bug here. Someone inserted unicode directionality mark and the rest is the result of unicode bidi algorithm doing its horrors. Display could perhaps be improved with adding embedding block inside the parenthesis.
Comment 2 Sumana Harihareswara 2011-10-07 20:14:40 UTC
Created attachment 9184 [details]
diff description/summary on right has two left parens instead of a left and a right

Still reproducible in 1.18wmf1.
Comment 3 Sumana Harihareswara 2011-10-07 20:16:23 UTC
The edit summary as listed in the revision history:


(cur | last) 00:20, 23 August 2009‎ Apples grow on pines (talk | changes)‎ (2,274 bytes) () (undo)
Comment 4 Sumana Harihareswara 2011-10-07 20:18:46 UTC
Created attachment 9185 [details]
revision history displaying the problematic edit summary

Hmm, in MediaWiki it looked more like:

<i>(</i>(odnu) <i>(</i>

Attaching screenshot.
Comment 5 Amir E. Aharoni 2011-10-11 11:16:14 UTC
As Niklas says, there's the Right-to-Left Overrirde (RLO) character here. It's pointless, but that's what it does - it forces all text to be right-to-left. It's not a MediaWiki bug by itself.

Such characters are already prohibited in page titles and it may make sense to prohibit them in edit summaries, too.
Comment 6 matanya 2012-06-27 12:28:55 UTC
This is not a bug in mediawiki, hence - closing as invalid.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links