Last modified: 2013-12-10 02:14:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20151 - Preferences for anonymous users
Preferences for anonymous users
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
User preferences (Other open bugs)
unspecified
All All
: Low enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-need-review
: 14602 23908 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-09 21:00 UTC by Andrew Garrett
Modified: 2013-12-10 02:14 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Proposed patch (3.70 KB, patch)
2009-08-09 21:19 UTC, Andrew Garrett
Details
Updated patch (3.92 KB, patch)
2009-10-29 13:46 UTC, Roan Kattouw
Details

Description Andrew Garrett 2009-08-09 21:00:27 UTC
Untested patch attached.
Comment 1 Roan Kattouw 2009-08-09 21:05:17 UTC
(In reply to comment #0)
> Untested patch attached.
> 

You seem to have forgotten it.

Also, I'm really curious to see how you're gonna implement this without fragmenting the Squid cache.
Comment 2 Andrew Garrett 2009-08-09 21:19:45 UTC
Created attachment 6450 [details]
Proposed patch

Needs XVO header.
Comment 3 Roan Kattouw 2009-10-29 13:46:35 UTC
Created attachment 6739 [details]
Updated patch

Updated patch so it applies cleanly to current trunk.

Per discussion in #wikimedia-tech, using XVO would make this possible, but:
* It would need to be restricted to a very small set of prefs to keep cache fragmentation (which increases exponentially with the number of allowed prefs) at bay
* There is the fear that enabling even a very limited version of anonymous preferences will open the floodgates to using XVO for all kinds of random purposes
Comment 4 Chad H. 2010-06-11 13:58:56 UTC
*** Bug 23908 has been marked as a duplicate of this bug. ***
Comment 5 p858snake 2011-04-30 00:09:49 UTC
*Bulk BZ Change: +Patch to open bugs with patches attached that are missing the keyword*
Comment 6 Sumana Harihareswara 2011-11-09 02:55:07 UTC
+need-review to signal to developers that this patch needs reviewing
Comment 7 Roan Kattouw 2011-11-20 13:29:08 UTC
I don't think this is a good idea, and operations is pretty radically opposed
to using this on Wikipedia. Closing WONTFIX.
Comment 8 Helder 2013-07-20 02:27:34 UTC
*** Bug 14602 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links