Last modified: 2012-09-27 01:11:11 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19790 - Vector skin does not indent subsection headers in table of contents
Vector skin does not indent subsection headers in table of contents
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.16.x
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://en.wikipedia.org/wiki/Precipit...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-17 19:39 UTC by Titoxd
Modified: 2012-09-27 01:11 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Titoxd 2009-07-17 19:39:41 UTC
The Vector skin's table of contents summarizes the headers in the page, but only shows the page's structure using numbered sections (e.g. 3, 3.1, 3.2) without using indentation as a backup. (Monobook and Modern use both.) I'm not sure if that is by design, but if it isn't, a fix would be very appreciated.
Comment 1 Trevor Parscal 2009-07-17 22:33:07 UTC
r53426 solved this.
Comment 2 Trevor Parscal 2009-07-17 22:33:43 UTC

*** This bug has been marked as a duplicate of bug 19795 ***
Comment 3 blurpeace 2009-07-17 23:20:21 UTC
I'm still experiencing the bug, even after purging my cache and reloading the pages.
Comment 4 Derk-Jan Hartman 2009-07-17 23:22:52 UTC
You are correct, this is not fixed. See cause of the problem here:  https://bugzilla.wikimedia.org/show_bug.cgi?id=19795#c1
Comment 5 blurpeace 2009-07-17 23:30:07 UTC
Yes, but why are we setting these as resolved?
Comment 6 Trevor Parscal 2009-07-17 23:53:21 UTC
This is fixed! r53426 reduced the specificity of #toc ul (used to be div#content #toc ul) and that made the following #toc ul ul rule actually influence the 2nd, 3rd, etc. level lists. I have tested it on many browsers.
Comment 7 blurpeace 2009-07-18 01:18:58 UTC
Well, I've just purged my cache in Firefox and the problem still occurs. I've tested it in IE8, and Google Chrome as well.
Comment 8 Roan Kattouw 2009-07-25 11:49:44 UTC
(In reply to comment #7)
> Well, I've just purged my cache in Firefox and the problem still occurs. I've
> tested it in IE8, and Google Chrome as well.
> 

That's because the fix hasn't been pushed live on Wikipedia yet. It will be in due course.
Comment 9 blurpeace 2009-07-26 15:17:17 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Well, I've just purged my cache in Firefox and the problem still occurs. I've
> > tested it in IE8, and Google Chrome as well.
> That's because the fix hasn't been pushed live on Wikipedia yet. It will be in
> due course.

Thank you for making that clear Roan; it's appreciated and noted. Trevor, you could have made that clear at first, but it's OK. I report things as I find them; I am in no way an expert over here.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links