Last modified: 2014-11-17 10:35:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19429 - secure links in email notification
secure links in email notification
Status: RESOLVED DUPLICATE of bug 29878
Product: MediaWiki
Classification: Unclassified
Email (Other open bugs)
unspecified
All All
: Low enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 1932 ssl
  Show dependency treegraph
 
Reported: 2009-06-29 03:46 UTC by John Mark Vandenberg
Modified: 2014-11-17 10:35 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description John Mark Vandenberg 2009-06-29 03:46:32 UTC
The enotif emails sent out from the wikis always include the unsecured link, and on some wikis it is inappropriate to log into the unsecured wiki over an insecure network.  e.g. arbcom wiki.

I see that we can modify mediawiki:enotif_body, but the diff is in "$PAGETITLE_URL" which doesnt appear to be configurable.

Could this be a site or user pref?
Comment 1 James F. 2011-08-03 08:37:17 UTC
Bumping this - needs to be part of the transition for the SSL-by-default concept to work (bug 27946). Needs to be both user-pref (for normal wikis) and site-pref (for "secure" wikis)?
Comment 2 Brion Vibber 2011-09-15 00:38:28 UTC
*** Bug 26294 has been marked as a duplicate of this bug. ***
Comment 3 Brion Vibber 2011-09-15 00:40:54 UTC
Merging this to bug 29878.

*** This bug has been marked as a duplicate of bug 29878 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links