Last modified: 2009-06-07 18:24:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19103 - Revisions with hidden attributes not shown in list=usercontribs
Revisions with hidden attributes not shown in list=usercontribs
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-06 09:18 UTC by Gurch
Modified: 2009-06-07 18:24 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Gurch 2009-06-06 09:18:39 UTC
For revisions with hidden attributes, prop=revisions correctly lists the visible attributes and supplies "commenthidden", "texthidden" parameters as appropriate. However, list=usercontribs does not show revisions with hidden attributes at all. [[Special:Contributions]] shows them, so the API should also be able to.
Comment 1 Happy-melon 2009-06-06 09:38:01 UTC
That Special:Contributions shows them at all is itself a bug (bug19091).  Displaying revisions where the username has been hidden, in a list where all the edits are by the same username, seems to rather defeat the object of the exercise.  However, edits where only the text and/or comment has been hidden should indeed be shown with appropriate blanks.
Comment 2 Gurch 2009-06-06 09:40:53 UTC
(In reply to comment #1)
> That Special:Contributions shows them at all is itself a bug (bug19091).

No, that bug is about the timestamps of revisions with deleted text being linked in [[Special:Contributions]] but not in the page history. This linking is pointless as all clicking it does is show an error message saying the revision can't be displayed because it's been hidden. Displaying the revisions themselves is most definitely not a bug (unless, as you mention, the username has been hidden).
Comment 3 Happy-melon 2009-06-06 09:52:12 UTC
Ah, I see.  Yes, in that case the API should definitely match the on-wiki version.
Comment 4 Roan Kattouw 2009-06-07 18:24:33 UTC
Done already in r49732 as part of the fix for bug 18554

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links