Last modified: 2014-11-01 18:31:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18613 - Make filling in the "reason" field for CheckUser checks compulsory
Make filling in the "reason" field for CheckUser checks compulsory
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CheckUser (Other open bugs)
unspecified
All All
: Normal enhancement with 3 votes (vote)
: ---
Assigned To: Aaron Schulz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 17:32 UTC by Sam Korn
Modified: 2014-11-01 18:31 UTC (History)
13 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Korn 2009-04-28 17:32:52 UTC
It is currently not compulsory to fill in the "reason" field when doing a CheckUser investigation.  This requirement would not be onerous on the user doing the check and would greatly aid oversight.
Comment 1 Aaron Schulz 2009-04-28 19:32:03 UTC
Can you put this on the CU mailing list?
Comment 2 Roger Davies 2009-04-28 21:13:15 UTC
Posted to the CU and [functionaries-en]. 
Comment 3 MZMcBride 2009-04-29 00:35:00 UTC
I would suggest a $wg variable with the default to off. While it's noble to want a reason each time, it doesn't seem reasonable to force non-Wikimedia wikis that have CheckUser installed to have someone type in a reason each time. Wikimedia wikis can, of course, set it however the sysadmins / community decide.
Comment 4 FT2 2009-04-29 01:14:21 UTC
Nice idea. In any event, like other action pages, fields to prompt uers to enter useful information is a good idea. I would have 3 fields for quick entry (compare: delete/block):

"Source". (On-wiki request, WMF hosted mailing list, private request by an enwiki functionary, private request by another project functionary, private request by anyone else, personal observation, recheck existing case, audit, other);

"Case". (Or wikilink to page, etc)

"Other info".

This is comparable to the block and delete pages, that have a dropdown box and also a box for "other information". In this case adding a dropdown box for "source", which is extremely useful for review.
Comment 5 Mike.lifeguard 2009-04-29 01:38:53 UTC
(In reply to comment #4)
> Nice idea. In any event, like other action pages, fields to prompt uers to
> enter useful information is a good idea. I would have 3 fields for quick entry

Oh, please no! One reason box is enough - /maybe/ a dropdown of predefined reasons could be useful in some cases (if optional). Your suggestion is pure bloat - just put it in the reason field.
Comment 6 Avi 2009-04-29 01:44:39 UTC
Perhaps not compulsory, but a reminder, similar to the gadget on EnWiki?
Comment 7 FT2 2009-04-29 02:08:15 UTC
(In reply to #5)

Have you checked the pages for blocking and deletion recently? These have multiple fields, and while none are compulsary, they do speed up entering useful information and (as Avi says) serve as a reminder.

Blocking for example - "Reason" and "Other/additional reason" (and a name field, 2 time fields, and 6 checkboxes).

Or deletion - "Reason for deletion" and "Other/additional reason".


Checkuser is a privacy based function, where fewer eyeballs see them, and accordingly a higher standard of checkability is needed. An edit with no edit summary is not much of an issue. A check lacking a clear explanation is different. A couple of optional fields to both prompt users to enter that data, and standardize it for ease of review, would be good. Not every project needs it, but some may wish to have it.
Comment 8 Herby 2009-04-29 07:55:28 UTC
Per Mike - most CU checks on non en wp wikis are pretty straightforward - multiple reasons are (IMO) unecessary.  However I fully agree that there should be a reason - I consider those who do not leave a reason very unhelpful to their fellow CUs.
Comment 9 Aaron Schulz 2009-05-15 18:04:22 UTC
Done in r50638
Comment 10 Brion Vibber 2009-05-18 19:14:27 UTC
The check and report code is duplicated in four places, which always makes me assume something'll break at some point. :)

Perhaps the check should be centralized, if it's common to all our submissions?
Comment 11 Aaron Schulz 2009-05-28 08:28:08 UTC
Duplication removed in r51040
Comment 12 xenocidic 2011-01-31 19:30:58 UTC
Is this working as intended? I've come across some checks on en.wiki that did not have a reason filled in, and even accidentally submitted one myself.
Comment 13 Marcin Cieślak 2011-01-31 19:52:39 UTC
Maybe because there is on $wgCheckUserForceSummary set on enwiki?
Comment 14 xenocidic 2011-01-31 19:55:01 UTC
Ah, so it's one of those cases where the functionality gets created and then we have to file a separate site request to actually get it turned on?
Comment 15 xenocidic 2011-01-31 20:21:00 UTC
https://bugzilla.wikimedia.org/show_bug.cgi?id=27078 , thanks Marcin.
Comment 16 xenocidic 2011-06-07 15:43:36 UTC
Reopened - for some reason, this isn't working as intended even though wgCheckUserForceSummary was set to true on enwp in bug 27078.

(See https://secure.wikimedia.org/wikipedia/en/w/index.php?title=User_talk:Reedy&oldid=433048205)
Comment 17 xenocidic 2011-06-21 12:28:53 UTC
After speaking with Aaron Schulz, the problem appears to be local config; re-closing; re-opening bug 27078.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links