Last modified: 2009-08-27 15:37:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17867 - $wgRCLinkDays perfect for SpecialWatchlist.php too
$wgRCLinkDays perfect for SpecialWatchlist.php too
Status: RESOLVED DUPLICATE of bug 2452
Product: MediaWiki
Classification: Unclassified
Watchlist (Other open bugs)
1.16.x
All All
: Normal trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
: easy, patch
Depends on: 19296
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 23:24 UTC by Dan Jacobson
Modified: 2009-08-27 15:37 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Finally make sense to the user if he clicks "all". I assume $wgRCMaxAge is the right variable. I also removed trailing whitespace. (3.40 KB, patch)
2009-04-30 01:33 UTC, Dan Jacobson
Details
Just use $wgRCLinkDays (765 bytes, patch)
2009-04-30 08:52 UTC, Dan Jacobson
Details

Description Dan Jacobson 2009-03-08 23:24:33 UTC
Gentlemen, visit your personal Special:Watchlist&days=0

Consider these two cases:

A) you see the message
   None of your watched items were edited in the time period
   displayed.

or B) some results are displayed.


In both cases the user _has no idea_ of what the period you are
displaying is.

You must tell him just far back in time you are reporting from!

Consider the Unix last(1) command.

$ last
jidanni  :0                            Mon Mar  9 02:29   still logged in
reboot   system boot  2.6.26-1-686     Mon Mar  9 02:16 - 07:18  (05:02)
jidanni  :0                            Fri Mar  6 03:51 - down   (05:33)
jidanni  :0                            Fri Mar  6 03:46 - 03:51  (00:04)
jidanni  :0                            Fri Mar  6 02:43 - 03:46  (01:03)
reboot   system boot  2.6.26-1-686     Fri Mar  6 02:41 - 09:25  (06:43)

wtmp begins Tue Mar  3 15:31:09 2009

Here it says that the reporting period starts at Mar 3.

That way we know if we are looking back a week, or a month, or a year.

Please do likewise.

By the way, other Special pages have similar problems: Bug #17750.
Comment 1 Chad H. 2009-04-23 00:35:01 UTC
Look up the screen just a bit, it says:

"Below are the last 0 changes in the last 3 days, as of 00:33, 23 April 2009" (date/time/changes may vary)

Marking WORKSFORME.
Comment 2 Dan Jacobson 2009-04-26 19:52:54 UTC
No it doesn't: if you click "All", the URL gets days=0, and the date information you mentioned disappears!

Comment 3 Chad H. 2009-04-27 14:29:02 UTC
Reclosing. If you clicked all, then you meant all changes ever. And it's not the default selection on the page, so you had to actively click it anyway (so it's not like it was already selected and you didn't know that)
Comment 4 Dan Jacobson 2009-04-30 01:33:13 UTC
Created attachment 6072 [details]
Finally make sense to the user if he clicks "all". I assume $wgRCMaxAge is the right variable. I also removed trailing whitespace.
Comment 5 Dan Jacobson 2009-04-30 08:52:11 UTC
Created attachment 6074 [details]
Just use $wgRCLinkDays

Why of course, how silly of me. $wgRCLinkDays is exactly what should
be used here! The administrator can customize it how he sees fit.
No need to expose days=0 to the user, as that will be the same as the
last choice if the administrator sets $wgRCFilterByAge=true. I could
kick myself for not seeing all this at first.
Comment 6 Alexandre Emsenhuber [IAlex] 2009-08-27 15:37:56 UTC

*** This bug has been marked as a duplicate of bug 2452 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links