Last modified: 2013-05-04 09:00:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17309 - Allow users to delete their own pages
Allow users to delete their own pages
Status: RESOLVED DUPLICATE of bug 14325
Product: MediaWiki
Classification: Unclassified
Page deletion (Other open bugs)
1.13.x
All All
: Normal enhancement with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 02:29 UTC by Dan Jacobson
Modified: 2013-05-04 09:00 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2009-02-02 02:29:37 UTC
Gentlemen, wouldn't it only be fair for MediaWiki to by default allow users to
delete their own User:Holmes and User_talk:Holmes pages.... or at least
their User:Holmes/Sandbox etc. subpages.
At the very least as long as all edits were made only by themselves.

Perhaps any page too, as long as all edits were made by them only.

Then they wouldn't have to go calling for mommy to clean up spills they could clean up themselves.
Comment 1 Chad H. 2009-02-03 00:01:06 UTC
I could've sworn this was a dupe of something, but I've spent the last 10 minutes searching and can't find it. 

I *do* remember though that similar requests have been shot down. A user doesn't "own" those pages from Mediawiki's point of view, no more than they own any other page. Suggest WONTFIX on this.
Comment 2 MZMcBride 2009-02-03 00:10:20 UTC
I also searched for a dupe, but couldn't find anything.

I don't agree that WONTFIX is the proper answer here. Perhaps this would be better suited for an extension, but the ability for users to delete their own user subpages is common among many projects.

I do think that an feature needs to be able to set pre-defined namespaces (by default only User: and User_talk: ?) to prevent someone from trying to revoke all of their image or redirect contributions or something silly like that. 
Comment 3 Splarka 2009-02-03 00:36:24 UTC
Closest dupe would probably be bug 14325

As said there, this requires a concept of ownership, which is not applicable outside of user interface (.css .js) pages.
Comment 4 Techman224 2009-02-03 00:41:37 UTC
There's a problem, if you allow people to delete their own talk pages, there is no way for people to see how many warning the user has, so I oppose this feature.
Comment 5 MZMcBride 2009-02-03 02:08:34 UTC
(In reply to comment #4)
> There's a problem, if you allow people to delete their own talk pages, there is
> no way for people to see how many warning the user has, so I oppose this
> feature.
> 

I was operating under the assumption that this would only work for pages with a single contributor.
Comment 6 Dan Jacobson 2009-02-04 01:50:09 UTC
Many of my first time users create pages by mistake and then can't
delete them (I would show you the list, but... Bug #17343),
perhaps leaving my site in frustration never to return.

Instead of "needing a call to the fire dept. when they could have
solved it themselves, instead of wasting taxpayers' money", why not:
If creator is them (thus perhaps not the two User:Holmes and User_talk:Holmes
pages, where we want reminders etc. to remain) and the only
editor is them, then allow them to delete it.
Comment 7 Splarka 2009-04-08 20:05:41 UTC
This bug and 14325 have now converged. They both pretty much agree pages should be deletable if the user is the only author.

*** This bug has been marked as a duplicate of bug 14325 ***
Comment 8 gqqnbig 2013-05-04 09:00:22 UTC
I support the initiative as long as there is only one contributor.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links