Last modified: 2013-06-18 15:56:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17343 - LogEventsList.php's getQueryInfo() INNER JOIN neglects log_user=0, causing deleteBatch.php's 'Delete page script' entries to be skipped
LogEventsList.php's getQueryInfo() INNER JOIN neglects log_user=0, causing de...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Page deletion (Other open bugs)
1.15.x
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on: 3732
Blocks: 16660
  Show dependency treegraph
 
Reported: 2009-02-04 01:42 UTC by Dan Jacobson
Modified: 2013-06-18 15:56 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2009-02-04 01:42:38 UTC
On the above URL we see the link "Deletion log", but when we go there,
http://radioscanningtw.jidanni.org/index.php?title=%E7%89%B9%E6%AE%8A:Log/delete&uselang=en
that entry is not there!

Suspecting the Delete page script is a special user,
I even tried adding a "bot" paramater that I read about on
http://www.mediawiki.org/wiki/Manual:User_rights .

If there is a way to reveal the hidden item, then it should me mentioned at the top of that Log page!

Also let us follow one of the other links offered:
http://radioscanningtw.jidanni.org/index.php?title=%E7%89%B9%E6%AE%8A:Contributions/Delete_page_script
nothing there either.
Comment 1 Dan Jacobson 2009-02-08 23:33:59 UTC
The entry, which will soon roll off RecentChanges, looks like:
1 February 2009
    * (Deletion log); 03:08 . . Delete page script (Talk | block) deleted "分類:157.7780"
However, even a WikiSysop, and even using
http://radioscanningtw.jidanni.org/index.php?title=特殊:Log/delete&hideminor=0&uselang=en
one does not see the entry.
Comment 2 Dan Jacobson 2009-02-15 06:00:08 UTC
Yes I can confirm the problem only occurs when the user is 'Delete page script'!
Comment 3 Dan Jacobson 2009-03-17 04:56:41 UTC
Gentlemen, I have found the problem.
Allow us to delete two pages,
$ echo 讀書會|php deleteBatch.php
$ echo 工作坊|php deleteBatch.php -u WikiSysop
Now using index.php?title=Special:Log&type=delete
why can we only see the latter, but not the former?
Allow us to do some queries,
SELECT * FROM wiki_logging ORDER BY log_timestamp DESC LIMIT 2;
+----------+------------+----------------+----------+---------------+--------
| log_type | log_action | log_timestamp  | log_user | log_namespace |log_title
+----------+------------+----------------+----------+---------------+--------
| delete   | delete     | 20090316221847 |        1 |             0 | 工作坊
| delete   | delete     | 20090316214131 |        0 |             0 | 讀書會
+----------+------------+----------------+----------+---------------+--------
We note that the row that doesn't show up in Special:Log&type=delete
is the row with log_user=0.

OK, now let's take a look at LogEventsList.php's function getQueryInfo:
...'INNER JOIN', 'user_id=log_user'...

OK, now let's do a query,
SELECT user_id,user_name FROM wiki_user ORDER BY user_id LIMIT 2;
+---------+--------------+
| user_id | user_name    |
+---------+--------------+
|       1 | WikiSysop    |
|       2 | Jidanni      |
+---------+--------------+
Do you see what I see?
That's right. There is no user_id=0 present!

In deleteBatch.php there is the line
$user = 'Delete page script';
The problem is there is no such user_name in the user table!

You might say "what's the big deal about that".
Well, the big deal is that 'Delete page script's deletions show up in
RecentChanges. But not in Special:Log&type=delete.

What compounds the frustration is that RecentChanges even has links on
every deletion entry, to Special:Log&type=delete. However, when one
clicks them, one cannot see any entries by the 'Delete page script'
user!

Therefore, please fix things so that
$ echo XYZ|php deleteBatch.php
will make entries in Special:Log&type=delete !
Thank you.
Comment 4 Roan Kattouw 2009-03-17 15:35:18 UTC
This'll be fixed automatically when bug 3732 is.
Comment 5 Dan Jacobson 2009-06-18 22:40:43 UTC
> This'll be fixed automatically when bug 3732 is.
Sorry. You're wrong.
Comment 6 Chad H. 2009-07-30 23:16:17 UTC
A more generalized description of the bug (and this transcends several scripts that have a maintenance username) is that they don't have userids since they're not in the user table. What we need to do is cleanup how we handle this pseudo users :)
Comment 7 Aaron Schulz 2011-11-05 04:44:13 UTC
Fixed with LogFormatter rewrite.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links