Last modified: 2012-02-22 12:36:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16890 - This page doesn't print correctly with IE7
This page doesn't print correctly with IE7
Status: RESOLVED WONTFIX
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Windows XP
: Lowest major with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Hdmi
: testme
: 8204 12291 17973 (view as bug list)
Depends on:
Blocks: 640
  Show dependency treegraph
 
Reported: 2009-01-05 16:09 UTC by Stephane BARIZIEN
Modified: 2012-02-22 12:36 UTC (History)
7 users (show)

See Also:
Web browser: Internet Explorer
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Sample printouts (247.25 KB, application/octet-stream)
2009-01-05 16:12 UTC, Stephane BARIZIEN
Details
Results with IE8 (134.43 KB, application/x-zip-compressed)
2009-06-04 12:23 UTC, Stephane BARIZIEN
Details

Description Stephane BARIZIEN 2009-01-05 16:09:43 UTC
I have found out (the hard way, i.e. by wasting paper -;) that the HDMI page on Wikipedia doesn't print correctly with IE7: some pages are output as blank.

The problem doesn't occur with other browsers.

It has been repro'ed on two vastly different Windows XP Pro SP3 computers, using completely different printers / printer drivers.

The attached zipfile shows results produced with various browsers, using Adobe's "PDF printer."
Comment 1 Stephane BARIZIEN 2009-01-05 16:12:54 UTC
Created attachment 5647 [details]
Sample printouts
Comment 2 Gurch 2009-01-05 16:45:36 UTC
Tried this myself with IE7/XP SP3.

The same thing seems to happen on other pages, examples being [[Blu-Ray Disc]], [[Hanford Site]] and [[Wikipedia:Administrators' noticeboard]], but not all pages. On some of them, only parts of pages are blanked out. I can't see anything that the affected pages have in common other than being quite long.
Comment 3 Alex Z. 2009-02-25 05:42:23 UTC
Likely related to or the same as bug 12291
Comment 4 p858snake 2009-03-14 02:54:19 UTC
*** Bug 17973 has been marked as a duplicate of this bug. ***
Comment 5 Maralia 2009-03-17 03:58:26 UTC
Ran into this today with a user at [[Talk:Asthma#Why can I not print this article after page 16?]]:

The user reported several blank pages upon printing (and print previewing) the article [[Asthma]]. I was able to reproduce the problem in IE 7, down to the same blank page numbers reported by the user. There were no likely culprits in the content at the points it went blank (no images, tables, templates, etc.). To check for formatting anomalies anyway, I copied a few pages of the text (including parts that had and had not printed) into a sandbox; it happened again—but at different points in the text. Occurs when using the printable version, too. Of the articles others noted above, I get blank pages in HDMI and Blu-Ray Disc but not Hanford Site.
Comment 6 Derk-Jan Hartman 2009-05-10 23:41:09 UTC
On en.wp we suspect this is caused by the CSS property line-height.

See also: http://en.wikipedia.org/wiki/MediaWiki_talk:Common.css/Archive_7#Printing_issues_with_IE7

We were thinking of adding this to a IE specific CSS stylesheet on en.wp, if that does solve the issue, perhaps we can "upmerge" that.... ?
Comment 7 Siebrand Mazeland 2009-06-04 11:08:16 UTC
Update Web browser.
Comment 8 Siebrand Mazeland 2009-06-04 11:35:36 UTC
Adding testme. Please test with Internet Explorer 8 and note the result here.
Comment 9 Stephane BARIZIEN 2009-06-04 12:22:41 UTC
Seems to work fine with IE8 -- see attached results.
Comment 10 Stephane BARIZIEN 2009-06-04 12:23:20 UTC
Created attachment 6195 [details]
Results with IE8
Comment 11 Siebrand Mazeland 2009-06-04 12:57:43 UTC
Closing WONTFIX. Work-around is to update to IE8 per comment 9.
Comment 12 Stephane BARIZIEN 2009-06-04 19:40:51 UTC
While this is a technically acceptable workaround, I have to note that many corporations (such as the company I work for) prohibit migration to IE8 -- until all browser-related applications have been adapted to IE8, that is.
Comment 13 Platonides 2009-07-29 22:15:59 UTC
*** Bug 8204 has been marked as a duplicate of this bug. ***
Comment 14 Derk-Jan Hartman 2010-11-10 21:03:27 UTC
*** Bug 12291 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links