Last modified: 2014-06-03 01:35:00 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15276 - Create a channel on Wikimedia IRC that logs newly created/unified accounts on all wikis
Create a channel on Wikimedia IRC that logs newly created/unified accounts on...
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal enhancement with 7 votes (vote)
: ---
Assigned To: Aaron Schulz
: crosswiki, shell
: 15271 (view as bug list)
Depends on: 66062
Blocks: 16599
  Show dependency treegraph
 
Reported: 2008-08-22 23:34 UTC by Cometstyles
Modified: 2014-06-03 01:35 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Cometstyles 2008-08-22 23:34:32 UTC
As per request from Brion on IRC to file a bug on this. It will be very useful to be able to know which accounts are unified and bots can be used to relay that info to Freenode IRC so that it can be watched by admins of different wikis and stewards alike and prior to accounts being unified automatically on creation, we have had problems of vandal accounts being  created and unified to bigger wikis (http://toolserver.org/~kylu/comet/locked.php) because they were never caught in time since ca.php is a bit slow and the alternate tool (http://toolserver.org/~sql/sul_log.php?) on toolserver lags a lot. I believe Tim said its possible for this to be done. It will be great if this can become a reality soon :) ..
Comment 1 Mike.lifeguard 2008-09-08 22:42:39 UTC
Werdna (I think) has made us a channel on irc.epstone.net/unifications but yes this really should be on irc.wikimedia.org
Comment 2 Brion Vibber 2008-09-08 22:44:54 UTC
Assigning to Aaron. Probably pretty easy, "just" need to stick in an extra call to the RC UDP notification. Depending how scary those interface are it might require a little refactoring of the interface.
Comment 3 Aaron Schulz 2008-09-24 11:26:01 UTC
Started this in r41148, which was randomly reverted. Someone else can do this.
Comment 4 Brion Vibber 2008-10-09 20:50:37 UTC
r41220 seems not to have reverted r41148 at all, but rather moved the newly-created function from GlobalFunctions to RecentChange::sendToUDP().
Comment 5 Aaron Schulz 2008-10-11 18:08:47 UTC
Done in r41973
Comment 6 Aaron Schulz 2008-10-11 23:03:39 UTC
Actually, this still needs some site configuration
Comment 7 Cometstyles 2008-10-30 08:40:30 UTC
well do something about it, we can no longer depend on Werdna's server or the toolserver, both fail all the time. its over 2 months now, ignoring it won't make it go away...
Comment 8 Brion Vibber 2008-11-03 22:17:12 UTC
Nov  3 22:15:28 10.0.2.157 apache2[29874]: PHP Fatal error:  Class 'UDP' not found in /usr/local/apache/common-local/php-1.5/extensions/CentralAuth/CentralAuthUser.php on line 1021

Looks like it needs updating for current codebase.
Comment 9 Aaron Schulz 2008-11-04 01:34:58 UTC
(In reply to comment #8)
> Nov  3 22:15:28 10.0.2.157 apache2[29874]: PHP Fatal error:  Class 'UDP' not
> found in
> /usr/local/apache/common-local/php-1.5/extensions/CentralAuth/CentralAuthUser.php
> on line 1021
> 
> Looks like it needs updating for current codebase.
> 

Fixed in r43181
Comment 10 Aaron Schulz 2008-11-16 05:43:33 UTC
00:49 brion: enabled UDP->IRC logging for CentralAuth user creations
Comment 11 Platonides 2008-12-20 23:08:16 UTC
The new channel is #central
Comment 12 Mike.lifeguard 2009-03-19 19:11:09 UTC
*** Bug 15271 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links