Last modified: 2007-07-07 07:02:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T12477, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 10477 - Watching pages silently fails in Firefox when zero-width non-joiner (ZWNJ) is present with AJAX enabled
Watching pages silently fails in Firefox when zero-width non-joiner (ZWNJ) is...
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
All All
: High major with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
Blocks: 1381
  Show dependency treegraph
Reported: 2007-07-06 11:20 UTC by Huji
Modified: 2007-07-07 07:02 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Huji 2007-07-06 11:20:36 UTC
Recently, an AJAX based system of watching/unwatching pages has been implemented. It doesn't work for some pages on Farsi Wikipedia. An example is provided as a link.

This problem occurs in Firefox, and is because of the use of Zero Width Non Joiner character in the title of the page. CategoryTree extension had the same problem (see bug 9789) which I tried to fix, but left midway. As this new bug has a more widespread effect, I think either the AJAX code should be rewritten in a way that it can handle ZWNJ (u200C) character correctly on all browsers (e.g. by substituting it with another character) or this newly feature should be turned off until a newer version of Firefox is released with this bug resolved.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-06 17:43:09 UTC
We should just fall back to normal watch when the UA is Firefox and ZWNJ is present, I guess (if it's even possible to check for ZWNJ . . .).  Are you sure this only happens with Firefox?  In particular, do you know if it happens with Mozilla, SeaMonkey, Camino, or other Gecko-based browsers?  We might want to whitelist known working browsers rather than blacklist bad ones, because this is a pretty significant failure.  Also, do you know what Mozilla bug number this corresponds to at, so that we can track when this is fixed upstream?
Comment 2 Huji 2007-07-06 19:51:20 UTC
I'm not sure about the other Mozilla based browsers. But if you follow the link I provided in bug 9789, you will notice the versin of Gecko engine which is supposed to be error-free in this regard. I guess all current stable versions of Gecko based browsers are affected by this bug, but I'm not sure. What I'm sure is, neither IE nor Opera are affected.
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-06 20:08:37 UTC
Okay, the Mozilla bug is 274152:
Comment 4 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-06 20:13:43 UTC
Hmm, or maybe it's not?  That seems to deal with string literals . . .
Comment 5 Brion Vibber 2007-07-06 21:51:48 UTC
Works for me, Firefox on Linux.

What's the problem?
Comment 6 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-06 22:06:23 UTC
The page actually goes on your watchlist, or you're just told it does?  I get the success message but my watchlist remains empty (thus "silently fails").
Comment 7 Brion Vibber 2007-07-06 22:17:09 UTC
Ahhhh -- so it *SAYS SUCCESS* but doesn't perform the task?

See, you should have said that. :)
Comment 8 Brion Vibber 2007-07-07 06:51:47 UTC
Fixed in r23834, and that change posted live.

Just making sure those chars are encoded in the JS string literals seems to do the job.
Comment 9 Huji 2007-07-07 07:02:47 UTC
Brion, this is just the same solution I found for bug 9789: to replace the characters. However, I only worked on ZWNJ and was not sure if ZWN (Zero Width Joiner) or any other character will result in a same problem or not. This is why I avoided to submit a patch for this bug (and bug 9789).

Well, you stood bolder than me, and yes, you've fixed it! Great job.

Note You need to log in before you can comment on or make changes to this bug.