Last modified: 2010-05-15 15:48:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8813 - Documentation of $wgGroupPermissions is poor
Documentation of $wgGroupPermissions is poor
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Documentation (Other open bugs)
1.9.x
All All
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: documentation
  Show dependency treegraph
 
Reported: 2007-01-28 20:20 UTC by Dan Jacobson
Modified: 2010-05-15 15:48 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2007-01-28 20:20:18 UTC
In DefaultSettings.php we see

 * Permission keys given to users in each group.
 * All users are implicitly in the '*' group including anonymous visitors;
 * logged-in users are all implicitly in the 'user' group. These will be
 * combined with the permissions of all groups that a given user is listed
 * in in the user_groups table.

the problem is that this is extra not clear. I could write a patch but
I'm not clear about it. What's not clear about it? I'm not clear. Tag
it for clarification, please.

Or delete the sentence and just tell them maybe in
http://www.mediawiki.org/wiki/Help:$wgGroupPermissions
it will be explained. Empty as of now.
Comment 1 Rob Church 2007-02-02 11:41:42 UTC
I've attempted to refactor the page on MediaWiki.org so it's a bit clearer
what's going on. The page was moved to Manual:$wgGroupPermissions and then the
redirect inexplicably deleted.

We should probably just update DefaultSettings.php to refer people to the more
comprehensive documentation, which, by the way, is located on a wiki so you can
edit it if you feel it's appropriate to do so.
Comment 2 Mark Clements (HappyDog) 2007-02-02 12:15:36 UTC
The redirect was deleted because it is in the PD Help: namespace.  It is a shame
to break the few external links pointing into the namespace, but redirects like
this break one of the fundamental aims of the PD help project which is to
provide a help namespace that is completely self-contained.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links