Last modified: 2011-07-12 04:17:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T10340, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 8340 - "Forgot to leave an edit summary" preference mis-fires when edit sessions are lost
"Forgot to leave an edit summary" preference mis-fires when edit sessions are...
Status: RESOLVED DUPLICATE of bug 8912
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
All All
: Low normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: testme
Depends on:
  Show dependency treegraph
Reported: 2006-12-21 01:14 UTC by Titoxd
Modified: 2011-07-12 04:17 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Titoxd 2006-12-21 01:14:39 UTC
I've found a bug that's currently ongoing on the live site. Here's the steps I
used to replicate it:

# First, I edited page, opening the edit window
# Filled out the edit summary, first thing
# Made the edit
# *Got the "We cannot process your edit due to a loss of session data. Please
try again" error message. I tried again.
# Got another lost-session message. Kept trying
# After n number of tries, my edit succeeds, however, I get a "you forgot to
leave an edit summary" message.
# Tried saving, lost my session again.

This happened several times yesterday, and I never changed the edit summary
between tries. I think that is the reason the "you did not enter an edit
summary" message was triggered.
Comment 1 Rotem Liss 2006-12-21 13:21:14 UTC
Bug 7200 (which was fixed in r16372) may be related. About the edit summary: was
it blank first, and was reset to be blank?
Comment 2 Aryeh Gregor (not reading bugmail, please e-mail directly) 2006-12-21 17:08:25 UTC
(bug 7220, not bug 7200)
Comment 3 Titoxd 2006-12-21 18:39:32 UTC
No, it was never blank, nor reset to blank. It was the same non-blank value all
the way along. 
Comment 4 Carl Fürstenberg 2006-12-21 19:06:34 UTC
Just testing, please ignore :)
Comment 5 Aaron Schulz 2007-01-02 04:31:58 UTC
I noticed that the auto summary for undo seems to trigger this as well.
Comment 6 Titoxd 2007-01-09 00:47:36 UTC
When is the MD5 hash for the edit summary calculated? If it is generated only
once, on the first call of ?action=edit, then this error shouldn't be triggered.
Same thing for the undo error, as the MD5 hash seems to be generated after the
"Undo revision..." summary is filled by MediaWiki.
Comment 7 Travis D 2007-01-23 20:40:32 UTC
FWIW: i usually find that this happens when either mediawiki can't reach a
memcached server or the memcached server is incorrectly configured in
Comment 8 Dan Collins 2011-07-12 04:15:03 UTC
Attempted to replicate, was unable to do so. Correct spelling in title and add testme tag.
Comment 9 Dan Collins 2011-07-12 04:17:36 UTC
Actually, this looks like a similar bug to bug 8912, and people there seem to have tried similar debugging steps, but much more recently.

*** This bug has been marked as a duplicate of bug 8912 ***

Note You need to log in before you can comment on or make changes to this bug.