Last modified: 2014-10-26 23:45:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 67958 - Block log formatting needs to be converted to the new method
Block log formatting needs to be converted to the new method
Status: RESOLVED DUPLICATE of bug 55402
Product: MediaWiki
Classification: Unclassified
Logging (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on:
Blocks: 24620
  Show dependency treegraph
 
Reported: 2014-07-13 21:57 UTC by Jackmcbarn
Modified: 2014-10-26 23:45 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jackmcbarn 2014-07-13 21:57:05 UTC
Formatting for block logs needs to be converted to use its own formatter, the way that delete, move, rights, etc. logs were. Currently, messages like unblocklogentry can't be properly translated into some languages, because they lack a parameter for the performer.
Comment 1 Nemo 2014-07-13 22:04:29 UTC
Yes, this needs to be done; thanks for filing.

Note: the first step, adding an "invisible" parameter for the performer/subject to be used in GENDER, can also be done without restructuring the log formatting.
https://www.mediawiki.org/wiki/Manual:Messages_API#Notes_about_gender.2C_grammar.2C_plural
Comment 2 Lewis Cawte 2014-10-26 22:25:33 UTC
This'll need to be done as part of 55402 as far as I can tell, duplicate bug?
Comment 3 Jackmcbarn 2014-10-26 23:45:45 UTC
Yeah.

*** This bug has been marked as a duplicate of bug 55402 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links