Last modified: 2014-07-11 04:17:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 67837 - Vector: update user icon
Vector: update user icon
Status: RESOLVED DUPLICATE of bug 41484
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Moiz Syed
: design
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-11 04:15 UTC by Steven Walling
Modified: 2014-07-11 04:17 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Current icon, when seen logged out (10.86 KB, image/png)
2014-07-11 04:15 UTC, Steven Walling
Details
Current icon, when logged in (17.32 KB, image/png)
2014-07-11 04:15 UTC, Steven Walling
Details

Description Steven Walling 2014-07-11 04:15:23 UTC
Created attachment 15902 [details]
Current icon, when seen logged out

user-icon.svg (with png fallback) is a subtle but highly visible part of Vector. It displays to all users, either next to the login link or next to their username. Consequently, this is an important piece of MediaWiki iconography.

This icon is pretty bad right now, in a variety of ways:

- It has too much detail.  
- It looks male. It's a bald person wearing blue suit. 
- It looks Caucasian. 

I don't think we want a little white man representing what being a user on a wiki is. Additionally, it's glossy, round look is too much for such a small icon. Even icon suites like those of GNOME (not exactly known for flat, trendy UI) are simpler than this. 

The ideal user icon should be:

- Genderless
- Neutral in color
- Simple and easy to discern even at very small sizes
Comment 1 Steven Walling 2014-07-11 04:15:39 UTC
Created attachment 15903 [details]
Current icon, when logged in
Comment 2 Steven Walling 2014-07-11 04:16:51 UTC
BTW, there is a placeholder icon in the BetaFeature "Compact personal bar". However, this is not final and should not be upstreamed to core.
Comment 3 Kunal Mehta (Legoktm) 2014-07-11 04:17:35 UTC

*** This bug has been marked as a duplicate of bug 41484 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links