Last modified: 2014-09-02 11:21:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 66524 - (Localisation update problems?) "More" menu dropdown shown in English (not translated/localized)
(Localisation update problems?) "More" menu dropdown shown in English (not tr...
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
Deployment systems (Other open bugs)
wmf-deployment
All All
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
https://it.wikivoyage.org/wiki/San_Pi...
: i18n
Depends on:
Blocks: 56295
  Show dependency treegraph
 
Reported: 2014-06-12 10:29 UTC by Andyrom75
Modified: 2014-09-02 11:21 UTC (History)
12 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Andyrom75 2014-06-12 10:29:43 UTC
On https://it.wikivoyage.org the "more" menu shown in the tab has the wrong translation ("More" instead of "Altro").

For example take a look at the top page of https://it.wikivoyage.org/wiki/San_Pietroburgo on the right of "Leggi", "Modifica" and "Cronologia".

I've seen that this issue is spread also to other projects (e.g. https://it.wiktionary.org/wiki/San_Pietroburgo) and also to other languages (e.g. https://nl.wikivoyage.org/wiki/Sint-Petersburg).

It's ok also to "correct & hide" the label as in https://it.wikipedia.org/wiki/San_Pietroburgo
Comment 1 Andre Klapper 2014-06-12 11:05:57 UTC
The only recent changes I'm aware of refering to "More" are bug 66363 / bug 66388. CC'ing Matma Rex in case he has an idea if there could be a relation.
Comment 2 Bartosz Dziewoński 2014-06-12 14:00:40 UTC
I can also reproduce on other wikis with uselang=it: for example https://pl.wikivoyage.org/wiki/Strona_główna?uselang=it also has the incorrect label.

This message has a translation: <https://translatewiki.net/wiki/MediaWiki:Vector-more-actions/it>. It was created a week ago and Wikimedia wikis are supposed to have some magic form of importing translations quicker than they would be otherwise. 

I'm sure that, in the worst case, this bug will fix itself next week with the next software deployment, but this might indicate some problems with the localization updates.
Comment 3 Sam Reed (reedy) 2014-06-13 14:45:45 UTC
It's correct in 1.24wmf9 at least https://test.wikipedia.org/wiki/MediaWiki:Vector-more-actions/it
Comment 4 Sam Reed (reedy) 2014-06-13 14:46:34 UTC
Manual run of localisation update shows no related errors

Updated extensions
git clone updated.
Running updates for 1.24wmf8 (on cawikibooks)
Rebuilding localization cache at 2014-06-13 14:24:35+00:00
Completed at 2014-06-13 14:29:45+00:00. Copying LC files to /a/common
Updated 203 JSON file(s) in '/a/common/php-1.24wmf8/cache/l10n'.
Syncing to Apaches at 2014-06-13 14:30:41+00:00
Synchronizing /a/common/php-1.24wmf8/cache/l10n to /usr/local/apache/common-local/php-1.24wmf8/cache/l10n...
mediawiki-installation:
fenari: Failed to add the RSA host key for IP address '2620:0:860:2:208:80:152:165' to the list of known hosts (/home/l10nupdate/.ssh/known_ho).
All done at 2014-06-13 14:36:44+00:00
Comment 5 Nemo 2014-06-13 21:35:58 UTC
(In reply to Sam Reed (reedy) from comment #3)
> It's correct in 1.24wmf9 at least
> https://test.wikipedia.org/wiki/MediaWiki:Vector-more-actions/it

But not *8: https://it.wikivoyage.org/wiki/MediaWiki:Vector-more-actions/it
https://gerrit.wikimedia.org/r/#/c/136610/ was merged on the 4th one day before the branching and is included in 1.24wmf8; the translation was made the day after and landed master the same evening https://gerrit.wikimedia.org/r/#/c/137752/1/languages/i18n/it.json,cm (after the branching point).

Can someone check if "vector-more-actions" is defined in the currently deployed English l10n files for 1.24wmf8?
Comment 6 Sam Reed (reedy) 2014-06-13 21:37:55 UTC
(In reply to Nemo from comment #5)
> (In reply to Sam Reed (reedy) from comment #3)
> > It's correct in 1.24wmf9 at least
> > https://test.wikipedia.org/wiki/MediaWiki:Vector-more-actions/it
> 
> But not *8: https://it.wikivoyage.org/wiki/MediaWiki:Vector-more-actions/it
> https://gerrit.wikimedia.org/r/#/c/136610/ was merged on the 4th one day
> before the branching and is included in 1.24wmf8; the translation was made
> the day after and landed master the same evening
> https://gerrit.wikimedia.org/r/#/c/137752/1/languages/i18n/it.json,cm (after
> the branching point).
> 
> Can someone check if "vector-more-actions" is defined in the currently
> deployed English l10n files for 1.24wmf8?

I didn't say it was there in 8 :P


https://github.com/wikimedia/mediawiki-core/blob/wmf/1.24wmf8/languages/i18n/en.json#L165
Comment 7 Nemo 2014-06-13 21:45:27 UTC
I know it's in the branch, but is it deployed? Because LocalisationUpdate clearly thinks not.
Comment 8 Sam Reed (reedy) 2014-06-13 21:50:06 UTC
reedy@mw1017:/usr/local/apache/common$ grep vector-more-actions php-1.24wmf8/languages/i18n/en.json
        "vector-more-actions": "More",


It's staged on a random apache. And I ran scap yesterday for the wmf9 deploy, which rebuilt wmf8 too.

Ran l10nupdate manually earlier today too
Comment 9 Nemo 2014-06-13 21:57:28 UTC
git log languages/i18n/en.json -> no more messages added to core since then

https://translatewiki.net/w/i.php?title=Special%3ATranslate&taction=proofread&group=!additions&language=it&limit=100&task=reviewall -> next added message to mediawiki/.* was pm-langcode-missing, added on the 5h and included in *8 https://gerrit.wikimedia.org/r/#/c/136538/

Translation committed the 6th, not in *8 https://gerrit.wikimedia.org/r/#/c/138085/1/i18n/pagetranslation/it.json,cm but correctly deployed on Meta https://meta.wikimedia.org/wiki/MediaWiki:Pm-langcode-missing/it

Seems to be a core deployment/LocalisationUpdate problem only. :(
Comment 10 Andyrom75 2014-06-19 15:50:21 UTC
I think the bug has been fixed.
Comment 11 Bartosz Dziewoński 2014-06-19 15:54:58 UTC
All wikis have been updated to MediaWiki version 1.24wmf9, which never had the problem per Reedy's comment 3, so the bug fixed itself per my comment 2. 

And now we'll probably never know what caused this :(
Comment 13 Andre Klapper 2014-06-25 09:03:16 UTC
I don't think this should really block deployment, but should be high priority to investigate.
Comment 14 Nemo 2014-06-26 21:25:40 UTC
Currently I see translations on e.g. [[MediaWiki:Vector-more-actions/ml]] (1.24wmf10) and I9395b0e1983122b12bedf003d6398da5ddfd5651 was backported to 1.24wmf11.

Let's test again next time a message is added to core?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links