Last modified: 2014-08-22 18:27:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 66516 - HTML Tags are stripped from extension output
HTML Tags are stripped from extension output
Status: RESOLVED FIXED
Product: Wikimedia Labs
Classification: Unclassified
deployment-prep (beta) (Other open bugs)
unspecified
All All
: Normal normal
: ---
Assigned To: Nobody - You can work on this!
:
: 66495 (view as bug list)
Depends on:
Blocks: tidy
  Show dependency treegraph
 
Reported: 2014-06-12 06:57 UTC by physikerwelt
Modified: 2014-08-22 18:27 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description physikerwelt 2014-06-12 06:57:37 UTC
Some HTML Tags are stripped from extension output on betalabs even though the "markerType" => 'nowiki' is used to prevent the output from further modifications.
This problem does not happen on my local vagrant test instance.

The concrete example that can be seen on http://deployment.wikimedia.beta.wmflabs.org/wiki/User:Anomie/Sandbox
if visited as logged in visitor with MathML rendering option in your user preference section is reported as BUG 66495. But I don't know if the bug is related to the Math extension or some other effect.
Comment 1 physikerwelt 2014-08-12 20:42:26 UTC
Can anybody reproduce this issue?
Comment 2 physikerwelt 2014-08-13 20:54:37 UTC
I could reproduce the bug locally by setting
  $wgUseTidy=true;
It seems to be tidy bug reported as
  http://sourceforge.net/p/tidy/patches/84/
before.
Comment 3 Gerrit Notification Bot 2014-08-13 22:45:10 UTC
Change 153965 had a related patch set uploaded by Physikerwelt:
Protect MathML from Tidy

https://gerrit.wikimedia.org/r/153965
Comment 4 Gerrit Notification Bot 2014-08-14 16:31:01 UTC
Change 154083 had a related patch set uploaded by Physikerwelt:
Protect MathML from Tidy

https://gerrit.wikimedia.org/r/154083
Comment 5 Gerrit Notification Bot 2014-08-14 16:32:31 UTC
Change 153965 abandoned by Physikerwelt:
Protect MathML from Tidy

Reason:
Abandon in favour of Ib48b91238c3eddd6a86b62f6ce57801d7058f0d8.
Thanks to TheDJ for the tip.

https://gerrit.wikimedia.org/r/153965
Comment 6 physikerwelt 2014-08-14 20:39:25 UTC
*** Bug 66495 has been marked as a duplicate of this bug. ***
Comment 7 Gerrit Notification Bot 2014-08-22 17:56:07 UTC
Change 154083 merged by jenkins-bot:
Protect MathML from Tidy

https://gerrit.wikimedia.org/r/154083

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links